Bug 854320 - parameter --sync-id isn't being accepted by ipvsadm.
parameter --sync-id isn't being accepted by ipvsadm.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipvsadm (Show other bugs)
6.5
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Ryan O'Hara
Cluster QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 11:57 EDT by Leon Keijser
Modified: 2012-09-24 15:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 15:56:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Keijser 2012-09-04 11:57:48 EDT
Description of problem:
The parameter --sync-id isn't being accepted by ipvsadm.

Version-Release number of selected component (if applicable):
ipvsadm-1.25-10.el6.x86_64

How reproducible:
Start ipvsadm in sync daemon mode with sync-id parameter

Steps to Reproduce:
1. start ipvsadm sync daemon as:
# ipvsadm --start-daemon master --sync-id 100 --mcast-interface eth0
  
Actual results:
ipvsadm throws an error:
--sync-id: unknown option

Expected results:
ipvsadm starts the sync daemon in master mode

Additional info:
none
Comment 2 Ryan O'Hara 2012-09-04 14:31:07 EDT
The ipvsadm option is '--syncid', not '--sync-id'. Please refer to ipvsadm(8) man page for more information.
Comment 3 Leon Keijser 2012-09-05 04:38:21 EDT
You're right, but the --syncid parameter is still not being accepted:

# ipvsadm --start-daemon master --syncid 50 --mcast-interface eth0
Illegal 'syncid' option with the 'start-daemon' command


Please consider reopening this ticket, thanks.
Comment 4 Ryan O'Hara 2012-09-05 09:15:27 EDT
I've reopened the ticket, but the command posted in comment #3 works for me:

# rpm -q ipvsadm
ipvsadm-1.25-10.el6.x86_64

# ipvsadm --start-daemon master --syncid 50 --mcast-interface eth0
# ipvsadm --list --daemon
master sync daemon (mcast=eth0, syncid=50)
Comment 5 Ryan O'Hara 2012-09-17 10:57:03 EDT
Any more information on this problem?
Comment 6 Leon Keijser 2012-09-19 08:02:42 EDT
Unfortunately not. I'm very sorry to have wasted your time. The machine that caused the issue has since been reinstalled and the problem with --syncid seems to have disappeared, so this ticket can be closed again. Again, my apologies.
Comment 7 Ryan O'Hara 2012-09-24 15:56:24 EDT
No problem. Glad that you got it working.

Note You need to log in before you can comment on or make changes to this bug.