Bug 854409 - Sorting resource events by 'Source Location' does not sort as expected
Sorting resource events by 'Source Location' does not sort as expected
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Jirka Kremser
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 19:05 EDT by Elias Ross
Modified: 2014-07-18 14:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-18 14:46:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshots of UI and db table dump (484.63 KB, application/zip)
2014-03-04 10:56 EST, Jirka Kremser
no flags Details

  None (edit)
Description Elias Ross 2012-09-04 19:05:10 EDT
Create a variety of events with different 'Source Location' values, such as host names.

View the resource list.

Sort by 'Source Location'; for example if you want to see by host these events.

The entries are not sorted by the value of the column, but likely something like an associated primary key value, which has no UI meaning.

See also Bug 846375
Comment 1 Jirka Kremser 2014-03-04 10:56:30 EST
Created attachment 870487 [details]
screenshots of UI and db table dump

I was not able to reproduce this issue. I've created multiple event sources with different source locations. However, it was sorted correctly in the UI (lexicographically) not by ID. Screenshots of screens and rhq_event_source table dump are attached.

Note You need to log in before you can comment on or make changes to this bug.