Bug 854473 - [RFE] [CLI] Support auto-completion on options prefixed with "--"
Summary: [RFE] [CLI] Support auto-completion on options prefixed with "--"
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-cli   
(Show other bugs)
Version: 3.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Ravi Nori
QA Contact: Ilia Meerovich
URL:
Whiteboard: infra
Keywords: FutureFeature, Improvement
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-05 06:49 UTC by Michael Pasternak
Modified: 2016-07-05 00:06 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 15:05:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 13023 None None None Never

Description Michael Pasternak 2012-09-05 06:49:17 UTC
On 09/04/2012 06:15 PM, Simon Grinberg wrote:
> 3. CLI: Auto complete does not work if the '--' is already written 
> meaning if I write 'nam' and hit tab, auto completion will change is to --name
> if I write --nam auto completion does will not work.

Comment 3 Sandro Bonazzola 2014-01-13 13:57:03 UTC
oVirt 3.4.0 alpha has been released including the fix for this issue.

Comment 4 Ilia Meerovich 2014-01-21 10:52:31 UTC
verified with 
ovirt-engine-cli-3.4.0.2-1.20140112.git01360ed.el6.noarch

Comment 5 Sandro Bonazzola 2014-03-31 15:05:19 UTC
This is an automated message: moving to Closed CURRENT_RELEASE since oVirt 3.4.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.