Bug 854482 - On win2003 i386 guest, host can't ping guest due to lower e1000 driver version (6.3.6.31)
On win2003 i386 guest, host can't ping guest due to lower e1000 driver versio...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.9
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 03:00 EDT by Wei Shi
Modified: 2012-12-10 06:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 06:00:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Shi 2012-09-05 03:00:27 EDT
Description of problem:
  Prepare a win2003 i386 guest with e1000 driver, can't ping the guest from host, but other machines on the different subnet can ping guest, and guest can ping others as well, switch the host to rhel5.8 release (2.6.18-308.el5xen), this problem occur again.
  rhel5.7 release (2.6.18-274.el5xen) and rhel5.6 release (2.6.18-238.el5xen) will lead to BSOD, it's because of BZ723755.
  Win2003 x64 guest won't have this problem


Version-Release number of selected component (if applicable):
Host: RHEL5.9 2.6.18-339.el5xen x86_64, xen-3.0.3-140.el5
      RHEL5.8 2.6.18-308.el5xen x86_64, xen-3.0.3-135.el5

Guest: Win2003 i386 hvm + e1000 driver


How reproducible:
100%


Steps to Reproduce:

1.Prepare a win2003 i386 guest with e1000 driver installed, and e1000 is the only nic on the guest.

2.ping the guest from host(start tcpdump on both side)

3.ping the host from guest(start tcpdump on both side)


Actual results:
  Host can't ping guest, but other machines from different subnet can ping.
  use tcpdump for both side to capture icmp package:
      host ping guest: guest will got ICMP-ECHO package
      PING 10.66.103.136 (10.66.103.136) 56(84) bytes of data.
      From 10.66.100.101 icmp_seq=1 Destination Host Unreachable
      From 10.66.100.101 icmp_seq=2 Destination Host Unreachable
      From 10.66.100.101 icmp_seq=3 Destination Host Unreachable
      From 10.66.100.101 icmp_seq=4 Destination Host Unreachable
      From 10.66.100.101 icmp_seq=5 Destination Host Unreachable
      From 10.66.100.101 icmp_seq=6 Destination Host Unreachable
      no ICMP packages captured on both side

      guest ping host: host won't got any ICMP package
      Request timed out.
      Request timed out.
      Request timed out.
      Request timed out.
      no ICMP packages captured on both side


Expected results:
  Host could ping guest and guest could ping host as well.
  Maybe this is a bug relate to default Microsoft e1000 driver problem, not our bug, but should added a technical note.


Additional info:
1.The following release can't reproduce this problem becuase of BSOD
      RHEL5.7 2.6.18-274.el5xen x86_64
      RHEL5.6 2.6.18-238.el5xen x86_64
  related bug:
  BZ723755 - win2003 i386 guest BSOD when created with e1000 nic
  https://bugzilla.redhat.com/show_bug.cgi?id=723755

2.No such problem on Win2003 x86_64, and i found the default e1000 driver version is different from i386

3.Attention: After updated the e1000 driver to Intel latest version, this problem disappear.
   Original Win2003 i386 e1000 driver
    provider:Microsoft
    date:10/1/2002
    version:6.3.6.31
    
   Intel Official e1000 driver(http://downloadcenter.intel.com/detail_desc.aspx?agr=Y&DwnldID=18719)
    provider:Intel
    date:8/20/2008
    version:8.10.3.0

   Original Win2003 x86_64 e1000 driver
    provider:Microsoft
    date:10/1/2002
    version:8.1.8.0

4. no such issue with rtl8139, tested with floowing matrix:
  RHEL5.9          2.6.18-339.el5xen
  rhel5.8 release (2.6.18-308.el5xen)
  rhel5.7 release (2.6.18-274.el5xen)
  rhel5.6 release (2.6.18-238.el5xen)
Comment 1 RHEL Product and Program Management 2012-09-05 03:27:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Miroslav Rezanina 2012-09-10 03:57:56 EDT
I created article describing this issue:

https://access.redhat.com/knowledge/solutions/205383

Please review and update if needed.
Comment 3 Wei Shi 2012-09-10 04:43:28 EDT
(In reply to comment #2)
> I created article describing this issue:
> 
> https://access.redhat.com/knowledge/solutions/205383
> 
> Please review and update if needed.

This article is ok, and you can add the windows guest version:
Windows 2003 Enterprise Edition with SP2

And i found another problem about windows guest, for Windows XP Professional Edition with SP3, these is no matched e1000 driver for our ioemu.e1000 device, so no network available, you can check with it and add it too.
Comment 4 RHEL Product and Program Management 2012-10-23 12:30:40 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Miroslav Rezanina 2012-12-10 06:00:21 EST
Article is published, closing.

Note You need to log in before you can comment on or make changes to this bug.