Bug 854484 - [REST-API] Can't update disk bootable attribute
[REST-API] Can't update disk bootable attribute
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.0
Assigned To: Michael Pasternak
Gadi Ickowicz
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 03:01 EDT by Michael Pasternak
Modified: 2016-02-10 12:06 EST (History)
13 users (show)

See Also:
Fixed In Version: si18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Pasternak 2012-09-05 03:01:50 EDT
On 09/04/2012 06:15 PM, Simon Grinberg wrote:
> [RHEVM shell (connected)]# update disk bc2454d0-2539-41c3-85c2-91cfbdfbede3 --vm-identifier BaseRHEL6 --bootable True
> 
> error: 
> status: 500
> reason: Internal Server Error
> detail: HTTP Status 500 - org.yaml.snakeyaml.error.YAMLException: No JavaBean properties found in org.ovirt.engine.api.model.Actions
Comment 2 Michael Pasternak 2012-09-06 05:54:13 EDT
the reason for that is [1], and exception caused by [2]

[1] https://bugzilla.redhat.com/show_bug.cgi?id=854480#c1
[2] http://lists.ovirt.org/pipermail/engine-devel/2012-September/002427.html 

note: update of disk from /api/disks/xxx yet supported by backend, see [2]
Comment 5 Jakub Libosvar 2012-10-02 10:49:35 EDT
Verified - command in description works in rhevm-backend-3.1.0-18.el6ev.noarch
rhevm-restapi-3.1.0-18.el6ev.noarch

Note You need to log in before you can comment on or make changes to this bug.