Bug 854493 - Deploy Tweetstream quick-start failed with compilation error
Deploy Tweetstream quick-start failed with compilation error
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 03:37 EDT by Gaoyun Pei
Modified: 2015-05-14 22:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2012-09-05 03:37:04 EDT
Description of problem:
Compilation error happened during installing a Tweetstream quick-start app

Version-Release number of selected component (if applicable):
http://buildvm-devops.usersys.redhat.com/puddle/build/OpenShift/Alpha/2012-08-29.1/DevOps/

How reproducible:
Always

Steps to Reproduce:
1.# rhc app create -a tweet -t jbossas-7 
2.# cd tweet && git remote add upstream -m master git://github.com/openshift/tweetstream-example.git && git pull -s recursive -X theirs upstream master 
3.Edit tweetstream/src/main/resources/twitter4j.properties and add twitter API keys:
oauth.consumerKey=WYWyn60DsoDDkSmy3AGhw
oauth.consumerSecret=uveHeAnasRBdJJevbl04P2nsqeZRxXM8HYqAyL2Vc
oauth.accessToken=331629113-X53jKX8CcdgBxu1oqfx9dYBj8iEQ8wBuxjKiPok4
oauth.accessTokenSecret=uTLdLwM5uoLepV4kyNUtPXUg0xc7MZKOeHBicBhw
4.# git push

Actual results:
<--snip-->
remote: [INFO] Compiling 15 source files to /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/target/classes
remote: [INFO] -------------------------------------------------------------
remote: [WARNING] COMPILATION WARNING : 
remote: [INFO] -------------------------------------------------------------
remote: [WARNING]  class TweetStreamListener
remote: /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[24,37] [deprecation] EventAbortedException in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[28,37] [deprecation] SessionTopicListener in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[60,33] [deprecation] SessionTopicListener in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[63,89] [deprecation] EventAbortedException in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[71,85] [deprecation] EventAbortedException in org.richfaces.application.push has been deprecated
remote: 
remote: [WARNING] /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/jms/TopicsInitializer.java:[84,91] [deprecation] EventAbortedException in org.richfaces.application.push has been deprecated
remote: 
remote: [INFO] 6 warnings 
remote: [INFO] -------------------------------------------------------------
remote: [INFO] -------------------------------------------------------------
remote: [ERROR] COMPILATION ERROR : 
remote: [INFO] -------------------------------------------------------------
remote: [ERROR] bootstrap class path not set in conjunction with -source 1.6
remote: /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/listeners/TweetStreamListener.java:[163,28] error: cannot find symbol
remote: 
remote: [ERROR] /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/listeners/TweetStreamListener.java:[162,1] error: method does not override or implement a method from a supertype
remote: 
remote: [INFO] 2 errors 
remote: [INFO] -------------------------------------------------------------
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] Reactor Summary:
remote: [INFO] 
remote: [INFO] tweetstream-demo .................................. SUCCESS [2:19.822s]
remote: [INFO] tweetstream-shared ................................ SUCCESS [7:06.498s]
remote: [INFO] tweetstream ....................................... FAILURE [1:06.017s]
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] BUILD FAILURE
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] Total time: 10:35.745s
remote: [INFO] Finished at: Wed Sep 05 15:34:23 HKT 2012
remote: [INFO] Final Memory: 25M/61M
remote: [INFO] ------------------------------------------------------------------------
remote: [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.1:compile (default-compile) on project tweetstream: Compilation failure: Compilation failure:
remote: [ERROR] bootstrap class path not set in conjunction with -source 1.6
remote: [ERROR] /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/listeners/TweetStreamListener.java:[163,28] error: cannot find symbol
remote: [ERROR] 
remote: [ERROR] /var/lib/stickshift/1a332fcb33344572ac848f3b3508ed8a/app-root/runtime/repo/tweetstream/src/main/java/org/richfaces/examples/tweetstream/dataserver/listeners/TweetStreamListener.java:[162,1] error: method does not override or implement a method from a supertype
remote: [ERROR] -> [Help 1]
remote: [ERROR] 
remote: [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
remote: [ERROR] Re-run Maven using the -X switch to enable full debug logging.
remote: [ERROR] 
remote: [ERROR] For more information about the errors and possible solutions, please read the following articles:
remote: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
remote: [ERROR] 
remote: [ERROR] After correcting the problems, you can resume the build with the command
remote: [ERROR]   mvn <goals> -rf :tweetstream
<--snip-->

Expected results:
Application should be installed and started successfully

Additional info:
Comment 1 Bill DeCoste 2012-10-03 13:46:15 EDT
Unable to recreate on ami-b51ea3dc, but I've upgraded the quickstart pom to use JDK 1.7
Comment 2 Gaoyun Pei 2012-10-12 01:48:16 EDT
Move this bug to OpenShift Product due to OnPremise would not support jbossas-7 cartridge.

And Verified this bug on devenv_2318.

Version/Release:
server: devenv_2318
client: rhc-0.99.5

Steps to verify:
1.Create a jbossas-7 app
   # rhc app create -a app1 -t jbossas-7 
2.# cd app1 && git remote add upstream -m master git://github.com/openshift/tweetstream-example.git && git pull -s recursive -X theirs upstream master 
3.Edit tweetstream/src/main/resources/twitter4j.properties and add twitter API keys:
oauth.consumerKey=WYWyn60DsoDDkSmy3AGhw
oauth.consumerSecret=uveHeAnasRBdJJevbl04P2nsqeZRxXM8HYqAyL2Vc
oauth.accessToken=331629113-X53jKX8CcdgBxu1oqfx9dYBj8iEQ8wBuxjKiPok4
oauth.accessTokenSecret=uTLdLwM5uoLepV4kyNUtPXUg0xc7MZKOeHBicBhw
4.Do git push

Actual results:
<--snip-->
...
remote: [INFO] --- maven-source-plugin:2.1.2:jar-no-fork (attach-sources) @ tweetstream ---
remote: [INFO] Building jar: /var/lib/openshift/5b811eb34f374a8f8992cd8d001c3814/app-root/runtime/repo/tweetstream/target/tweetstream-sources.jar
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] Reactor Summary:
remote: [INFO] 
remote: [INFO] tweetstream-demo .................................. SUCCESS [37.394s]
remote: [INFO] tweetstream-shared ................................ SUCCESS [1:22.801s]
remote: [INFO] tweetstream ....................................... SUCCESS [19.702s]
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] BUILD SUCCESS
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] Total time: 2:22.707s
remote: [INFO] Finished at: Fri Oct 12 01:35:34 EDT 2012
remote: [INFO] Final Memory: 27M/65M
remote: [INFO] ------------------------------------------------------------------------
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/deploy
remote: hot_deploy_added=false
remote: Found 127.0.253.129:8080 listening port
remote: Done
remote: Running .openshift/action_hooks/post_deploy
To ssh://5b811eb34f374a8f8992cd8d001c3814@app1-1011.dev.rhcloud.com/~/git/app1.git/
   05abdb9..fb51e11  master -> master


The Tweetstream url http://app1-1011.dev.rhcloud.com/pages/home.jsf shows correctly

Note You need to log in before you can comment on or make changes to this bug.