Bug 854500 - ovirt-engine-backend: Need to rephrase "oVirt" value for VM origin field
ovirt-engine-backend: Need to rephrase "oVirt" value for VM origin field
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Omer Frenkel
Oded Ramraz
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 04:14 EDT by Oded Ramraz
Modified: 2012-12-04 15:08 EST (History)
10 users (show)

See Also:
Fixed In Version: si18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-09-05 04:14:56 EDT
Description of problem:

Need to rephrase "oVirt"  value for VM origin field . Should be RHEV or something similar . 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 lpeer 2012-09-05 04:25:41 EDT
Oded - what is the origin of the VM?
We have 4 possible values for origin: RHEV(0), VMWARE(1),XEN(2),OVIRT(3);

If the VM was exported in RHEV and the origin says ovirt that's a bug we should fix otherwise it should stay ovirt.
Comment 2 Itamar Heim 2012-09-05 04:27:29 EDT
as part of branding, need to update the config in rhev for origin to be rhev...

    /**
     * The origin type to be used for VM and VM template creation
     */
    @TypeConverterAttribute(String.class)
    @DefaultValueAttribute("OVIRT")
    OriginType(336),
Comment 3 lpeer 2012-09-05 04:35:24 EDT
The value is taken from config.sql (the java code is used as default in case the value is not in the DB), but it looks like it is OVIRT there as well, so need to fix that.
Comment 4 Doron Fediuck 2012-09-05 04:52:05 EDT
(In reply to comment #3)
> The value is taken from config.sql (the java code is used as default in case
> the value is not in the DB), but it looks like it is OVIRT there as well, so
> need to fix that.

Why not fix both, so code is consistent with the DB scripts?
Comment 5 Omer Frenkel 2012-09-05 05:18:42 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > The value is taken from config.sql (the java code is used as default in case
> > the value is not in the DB), but it looks like it is OVIRT there as well, so
> > need to fix that.
> 
> Why not fix both, so code is consistent with the DB scripts?

it doesn't really matter, code defaults are used only if value is missing in db,
which should not happen.
Comment 7 Omer Frenkel 2012-09-05 05:38:47 EDT
https://gerrit.eng.lab.tlv.redhat.com/#/c/1850/
Comment 13 Oded Ramraz 2012-09-13 05:40:11 EDT
Verified si18:

Origin fields value is now RHEV instead of oVirt

Note You need to log in before you can comment on or make changes to this bug.