Bug 854503 - Build from .spec fails on SLES 11 due to BuildRequires python-ctype
Build from .spec fails on SLES 11 due to BuildRequires python-ctype
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
pre-release
Unspecified Linux
low Severity low
: ---
: ---
Assigned To: Niels de Vos
http://lists.nongnu.org/archive/html/...
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 04:18 EDT by Niels de Vos
Modified: 2013-07-24 13:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:40:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2012-09-05 04:18:46 EDT
From: 	Jörg Petersen

I'm running GlusterFS on SLES 11, and just tried to compile the new QA.
Had to make a little change to the spec file, because there's no
"python-ctypes" in SLES:

cloudstor2 /usr/src/packages/SPECS # diff -u glusterfs.spec-3.3.1qa2
glusterfs.spec
--- glusterfs.spec-3.3.1qa2     2012-08-30 13:39:20.000000000 +0200
+++ glusterfs.spec      2012-09-05 09:15:54.261831380 +0200
@@ -50,9 +50,10 @@
 BuildRequires: gcc make automake libtool
 BuildRequires: ncurses-devel readline-devel openssl-devel
 BuildRequires: libxml2-devel
-BuildRequires: python-ctypes
 %if 0%{?suse_version}
 BuildRequires: python-devel
+%else
+BuildRequires: python-ctypes
 %endif
 Requires: openssl
Comment 1 Niels de Vos 2012-09-05 04:21:17 EDT
Posted http://review.gluster.org/3906 for inclusion

Note You need to log in before you can comment on or make changes to this bug.