Bug 854531 - Should show rhc-port-forward be deprecated when use rhc-port-forward command
Should show rhc-port-forward be deprecated when use rhc-port-forward command
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 05:33 EDT by Rony Gong
Modified: 2015-05-14 22:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhc-0.98.12-1+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-09-05 05:33:46 EDT
Description of problem:
story link:
https://rally1.rallydev.com/#/4670255914d/detail/userstory/7654436964




Version-Release number of selected component (if applicable):
fork_ami_US2833_74


How reproducible:
always

Steps to Reproduce:
1. Create non-scalable app (run this command in instance as root)
2. Use rhc-port-forward -a qjboss
3.
  
Actual results:
[root@ip-10-120-202-201 usr]# rhc-port-forward -a qjboss
Password: 

Checking available ports...

Binding java -> 127.0.250.129:3528...
Binding java -> 127.0.250.129:4447...
Binding java -> 127.0.250.129:5445...
Binding java -> 127.0.250.129:5455...
Binding java -> 127.0.250.129:8080...
Binding java -> 127.0.250.129:9990...
Binding java -> 127.0.250.129:9999...
Use ctl + c to stop



Expected results:
show rhc-port-forward is deprecated. please use rhc port-forward


Additional info:
Comment 1 Rony Gong 2012-09-05 23:29:15 EDT
Today, I retest on instance that created from fork_ami_US2833_AND_BZ284531
find the adding string like "
cWdvbmcxQHJlZGhhdC
5jb20"
I think they should be removed.
[root@ip-10-120-179-251 ~]# rhc port-forward -a qjboss
Password: 

cWdvbmcxQHJlZGhhdC
5jb206
Checking available ports...
Binding java -> 127.0.250.129:3528...
Binding java -> 127.0.250.129:4447...
Binding java -> 127.0.250.129:5445...
Comment 2 Rony Gong 2012-09-06 05:22:02 EDT
And test in fork_ami_US2833_AND_BZ284531, I could find the prompt message about deprecated rhc-port-forward when type "rhc-port-forward -a app"
Comment 3 Xiaoli Tian 2012-09-09 23:04:14 EDT
Assign it back since it still outputs some unexpected string according to comment 1
Comment 4 John (J5) Palmieri 2012-09-10 11:22:20 EDT
Weird string output has been fixed in bug#854152.

rhc-port-forward simply needs a puts line which prints out a warning:

puts "Warning: This command is deprecated and will be removed in the future. Please use 'rhc port-forward' instead."
puts""
Comment 5 Fabiano Franz 2012-09-10 21:02:52 EDT
Fixed in rhc-0.98.12-1+.
Comment 6 Rony Gong 2012-09-11 04:06:37 EDT
Verified on rhc-0.98.13
[qgong@localhost int]$ rhc-port-forward -a qphp
Warning: This command is deprecated and will be removed in the future. Please use 'rhc port-forward' instead.

Password: ******

Checking available ports...

Binding httpd -> 127.7.212.1:8080...
Use ctl + c to stop


[qgong@localhost int]$ rhc port-forward -a qphp
Password: ******

Checking available ports...
Binding httpd -> 127.7.212.1:8080...
Binding mysqld -> 127.7.212.1:3306...
Forwarding ports, use ctl + c to stop
^C
RESULT:
Ending port forward

Note You need to log in before you can comment on or make changes to this bug.