Bug 854560 - lsof - Inconsistency between man page and help
lsof - Inconsistency between man page and help
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lsof (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 06:41 EDT by Filip Holec
Modified: 2016-04-18 06:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 05:52:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Holec 2012-09-05 06:41:21 EDT
Description of problem:
These options are present in man, but not in help:
* -A
* -C
* -D
* -k
* -m
* -z

Version-Release number of selected component (if applicable):
lsof-4.86-4.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Check man page
2. Check --help option
  
Actual results:
Inconsistent man page/help

Expected results:
Consistent man page/help

Additional info:
Comment 1 Peter Schiffer 2012-11-01 12:45:36 EDT
Hi Filip,

the lsof man page is static and describes all the options. There is a note in every option which is not available on all platforms/architectures where it is available and why.
The lsof usage is dynamically created according to the options available.

Since these differences are well documented, I wouldn't like to change them. Please, let me know if this is OK with you, and if yes, I'll close this bug.

Thanks,

peter
Comment 2 Filip Holec 2012-11-02 06:19:23 EDT
Hello Peter,

thank you for explanation. I'm OK with closing this bug.

Best regards,

Filip

Note You need to log in before you can comment on or make changes to this bug.