Bug 854625 - Opening a file from another trusted domain fails
Opening a file from another trusted domain fails
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Amar Tumballi
Lalatendu Mohanty
:
Depends On: 765229
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 09:21 EDT by Vidya Sakar
Modified: 2013-12-18 19:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 765229
Environment:
Last Closed: 2013-09-23 18:39:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-09-05 09:21:25 EDT
+++ This bug was initially created as a clone of Bug #765229 +++

Had two AD Domains - 10.1.10.111 and 10.1.10.112 which have 2 way trust between them. There is  Created an image file on the gluster mount using samba re-export from 10.1.10.112 and tried opening the file from the other domain. The file failed to open with an error message said that it wasn't a valid image file. Was able to open it without issues from the backend directly.

--- Additional comment from sgowda@redhat.com on 2012-01-09 07:47:05 EST ---

Does this issue still exist?

--- Additional comment from amarts@redhat.com on 2012-07-11 00:01:24 EDT ---

Bug timeout approaching. Need someone from QA confirm this issue exists (issue seen a year back).
Comment 4 Lalatendu Mohanty 2013-08-28 10:20:03 EDT
This is not an issue any more. I could access the rhs-samba share from a different domain (i.e. a child domain) with 2 way trust relation between them.

The tricky part of to create a universal user group in the parent domain, adding parent and child domain users to the group. Then change the group of the rhs folder to the ad group.
Comment 5 Scott Haines 2013-09-23 18:39:10 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:43:41 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.