Bug 854626 - Replace-brick status says migration complete even though data-self heal hasn't been completed.
Replace-brick status says migration complete even though data-self heal hasn'...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs-server (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Pranith Kumar K
shylesh
: ZStream
Depends On: GLUSTER-3595
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 09:23 EDT by Vidya Sakar
Modified: 2015-05-13 12:30 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.50rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: GLUSTER-3595
Environment:
Last Closed: 2014-02-25 02:22:30 EST
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-09-05 09:23:17 EDT
+++ This bug was initially created as a clone of Bug #765327 +++

I have a distribute replicate setup 2x2, mounted on a fuse. 
i started replacing a brick, then i paused and then aborted it. Later i again started the replace-brick on same bricks. When it got succeeded , i checked the status, it said migration completed. But if you look in the back end, all files are not completely self-healed. But after sometime all files got self healed.

--- Additional comment from vijaykumar@gluster.com on 2011-10-17 05:42:34 EDT ---

I followed the same thing with 3.2.4 on RHEL-6.1 , i am observing the same behavior.

--- Additional comment from amarts@redhat.com on 2012-07-11 02:43:18 EDT ---

need to check if its happening on 3.3.0
Comment 2 Vijaykumar Koppad 2013-01-10 04:20:39 EST
Need to know , in which version it is fixed.
Comment 5 Sachidananda Urs 2013-08-27 05:23:30 EDT
Since we are not supporting data migration in replace-brick moving this out of Big Bend.
Comment 8 shylesh 2014-01-24 06:40:21 EST
Verified sanity only on 3.4.0.57rhs-1.el6rhs.x86_64
Comment 10 errata-xmlrpc 2014-02-25 02:22:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.