Bug 854659 - Glusterfs compilation on fuse mount errors out while doing graph change in a loop
Glusterfs compilation on fuse mount errors out while doing graph change in a ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Raghavendra G
Sachidananda Urs
:
Depends On: 835057
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 09:50 EDT by Vidya Sakar
Modified: 2013-09-23 18:43 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 835057
Environment:
Last Closed: 2013-09-23 18:39:11 EDT
Type: Bug
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-09-05 09:50:58 EDT
+++ This bug was initially created as a clone of Bug #835057 +++

Description of problem: The make process errors out while compiling glusterfs on the fuse mount and trigger graph change in a loop.


Version-Release number of selected component (if applicable): RHS RC2


How reproducible: Consistently


Steps to Reproduce:
1. Compile glusterfs on the fuse mount
2. Trigger graph change using volume set command
3.
  
Actual results:

:(.text+0x4ba0): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x4d00): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x4e60): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x5120): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x5280): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x53e0): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Warning: size of symbol `' changed from 342 in .libs/afr-dir-write.o to 1673 in .libs/afr-dir-write.o
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x5a70): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Warning: size of symbol `' changed from 1673 in .libs/afr-dir-write.o to 1721 in .libs/afr-dir-write.o
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x6130): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '38', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Warning: size of symbol `' changed from 1721 in .libs/afr-dir-write.o to 1817 in .libs/afr-dir-write.o
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x6850): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Warning: size of symbol `' changed from 1817 in .libs/afr-dir-write.o to 1865 in .libs/afr-dir-write.o
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x6fa0): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Warning: size of symbol `' changed from 1865 in .libs/afr-dir-write.o to 1790 in .libs/afr-dir-write.o
/usr/bin/ld: Dwarf Error: found dwarf version '8', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x76a0): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Warning: size of symbol `' changed from 1790 in .libs/afr-dir-write.o to 1870 in .libs/afr-dir-write.o
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o: In function `no symbol':
:(.text+0x7df0): multiple definition of `no symbol'
/usr/bin/ld: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
.libs/afr-dir-write.o::(.text+0x0): first defined here
/usr/bin/ld: Warning: size of symbol `' changed from 1870 in .libs/afr-dir-write.o to 1790 in .libs/afr-dir-write.o
collect2: ld returned 1 exit status
make[4]: *** [afr.la] Error 1
make[3]: *** [install-recursive] Error 1
make[2]: *** [install-recursive] Error 1
make[1]: *** [install-recursive] Error 1
make: *** [install-recursive] Error 1



Expected results: Shouldn't error out.


Additional info:

--- Additional comment from amarts@redhat.com on 2012-07-11 06:59:22 EDT ---

not happening for us. can you try to reproduce and give the system control once this happens?
Comment 2 Sachidananda Urs 2012-11-20 07:55:37 EST
This is not fixed in glusterfs-3.3.0rhsvirt1-7.el6rhs
With multiple graph changes, kernel/glusterfs compile still fails.
Comment 5 Sachidananda Urs 2012-11-21 01:03:57 EST
This was tested on glusterfs-3.3.0rhsvirt1-8.el6rhs
Comment 6 Amar Tumballi 2012-11-22 01:55:55 EST
this needs a proper fd-migration to get fixed (and is already fixed in upstream), but backporting the fixes would make the codebase unstable (as there are more than 5 patches and more than 500lines of code which is needed to handle this). Not giving a devel ack till this is viewed as very critical from PM.

(also as this is not part of virtualization image hosting effort, removing the  the appropriate flags)
Comment 7 Sachidananda Urs 2012-12-11 07:30:42 EST
In the release: glusterfs-3.4.0qa4-1 this issue is fixed.

To verify:

Compile kernel/GlusterFS, make sure you have many runs of compilation going on. And do a series of gluster set/unset operations so that a lot of graph changes happen. The compilation should not fail...
Comment 10 Scott Haines 2013-09-23 18:39:11 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 11 Scott Haines 2013-09-23 18:43:41 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.