Bug 85468 - RedHat 8 no Scandinavian characters
RedHat 8 no Scandinavian characters
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gedit (Show other bugs)
8.0
i586 Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-03 02:49 EST by anzac
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 13:28:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description anzac 2003-03-03 02:49:05 EST
Description of problem:
I cannot use Finnish characters in any documents/scripts using any supplied
editor even though I selected Finnish and English(GB) during installation. In
both KDE and Gnome I have selected Finnish keyboard.  Have tried to use SETUP to
specify the keyboard to use to no avail.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.Open an editor (kedit,gedit)
2.Write a script. For example PHP.
3.Use scandinavian characters and view using Mozilla. 
    
Actual results:
Rubbish characters will result.

Expected results:
Scandinavian characters

Additional info:
Comment 1 anzac 2003-03-07 06:12:03 EST
Since posting this message I have attempted many different clean installs always
with the same result. When I select FI-latin1 or SE-Latin1, during install and
set locale and keyboard correctly after install, RedHat8 refuses to use/show
Scandinavian characters in my programs/scripts when they run in the Internet.
RedHat 8 'ignores' browser character set selections by users of my programs. The
behaviour is not browser-dependant. During boot, Redhat boot scripts do not
accept some characters in the RedHat keytable. A typical boot log has been sent
to RedHat support. The log-on screen is in Finnish, KDE shows Finnish text as
does Gnome but obviously that is not enough for a programmer!
Comment 2 Havoc Pennington 2003-07-30 18:16:14 EDT
gedit probably saves in UTF-8, what encoding are you using in Mozilla?

We need to make a list of exact cases where things break, and then 
break this bug into separate bugs for each app that has problems.

For example, if Mozilla defaults to an encoding other than the locale 
encoding for viewing local files, that is probably wrong.

If you run the command "locale" what is the output?
Comment 3 Havoc Pennington 2003-08-05 17:13:07 EDT
Please move bug out of NEEDINFO if you add more details.
Comment 4 Havoc Pennington 2004-11-03 13:28:36 EST
Closing as RHL8 is no longer relevant

Note You need to log in before you can comment on or make changes to this bug.