Bug 854769 - Mountain Lion and git issues on Getting Started page
Mountain Lion and git issues on Getting Started page
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Sumana Annam
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 19:08 EDT by Sumana Annam
Modified: 2015-05-14 22:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sumana Annam 2012-09-05 19:08:53 EDT
Description of problem:

Followed the instructions from "Getting started" Mac section for setting up my Mac environment and ran into few hurdles on Mountain Lion 10.8.

1) The "git for OS X" URL link we point to, does not have DMG for 10.8
2) Also just installing XCode wouldn't be sufficient, one needs to install optional components called "command line tools" which bring in git. I am not sure whether this was always true but it is for Xcode 4.4.1.

Either way, IMO we should clarify this in our "Getting Started" Mac instructions.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Clayton Coleman 2012-09-07 13:50:51 EDT
You should have access to change this - please jump in and alter the text!
Comment 2 Sumana Annam 2012-09-19 19:10:15 EDT
Decided to do a KB instead;

link: https://openshift.redhat.com/community/kb/kb-e1068-git-installation-issues-on-mountain-lion-os-x-108
Comment 3 Xiaoli Tian 2012-09-21 01:14:43 EDT
Move it to ON_QA then since the KB is on PROD now
Comment 4 Yujie Zhang 2012-09-21 02:15:04 EDT
(In reply to comment #2)
hi Sumana, thanks for adding this KB page, I will verify this bug now.

Note You need to log in before you can comment on or make changes to this bug.