Bug 854771 - ogg playback broken in firefox-15.0-1.fc16.x86_64
ogg playback broken in firefox-15.0-1.fc16.x86_64
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 19:16 EDT by Ian Malone
Modified: 2012-12-21 08:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-21 08:54:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 789247 None None None 2012-09-06 16:14:37 EDT

  None (edit)
Description Ian Malone 2012-09-05 19:16:01 EDT
Description of problem:
On updating to firefox-15.0-1.fc16.x86_64 sound clips on http://www.russianlessons.net/lessons/lesson2_main.php (e.g. http://www.russianlessons.net / audio / lesson3-13.ogg : I've broken the link because I doubt they'd appreciate direct linking to media files) are broken. Downgrading to xulrunner-14.0.1-3.fc16.x86_64 + firefox-14.0.1-2.fc16.x86_64 works and confirms the problem is somewhere in the FF15 packages.

Version-Release number of selected component (if applicable):
firefox-15.0-1.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Visit site, click the green 'play' buttons, only a 'clipped' burst of sound occurs, same visiting the ogg link directly (so not a problem with the presence of mp3 alternatives).

Expected results:
Sound clip plays.

Additional info:
Downloading the ogg file and playing in ogg123 is fine, oggz-validate and oggz-info show no problems with the file, plays okay in the earlier Firefox.
Other ogg files seem to work okay, may be an issue with the sample rate (22kHz, rather than 44k or 48k).
Comment 1 Ian Malone 2012-09-06 06:18:38 EDT
Further data point, using FF15 under Windows XP and accessing the .ogg directly also works, so possibly a problem with the Fedora build.
Comment 2 Martin Stransky 2012-09-06 06:30:49 EDT
Works for me as expected, with Firefox 15. Can you test a binary from mozilla.com?
Comment 3 Ian Malone 2012-09-06 16:14:37 EDT
Okay, I've tried a few things and there's a complicated picture:
Mozilla binaries from http://releases.mozilla.org/pub/mozilla.org/firefox/releases/ EN-US x86_64 builds:

firefox-15.0.tar.bz2
firefox-15.0.1.tar.bz2
firefox-16.0b2.tar.bz2
- Broken on all of these.

firefox-14.0.1.tar.bz2
- Works on this.

Additionally, on my laptop on F17 Firefox 15 works okay.

Messages to console while trying to play the files in Firefox 15:
nsBuiltinDecoderStateMachine::RunStateMachine queuing nsBuiltinDecoder::PlaybackEnded
nsBuiltinDecoder::PlaybackEnded mPlayState=3

- but I don't seem to get those when playing ogg files that do work.

Filing with Mozilla.
Comment 4 Martin Stransky 2012-09-12 07:18:49 EDT
Please try the workaround in https://bugzilla.mozilla.org/show_bug.cgi?id=789726#c2
Comment 5 Ian Malone 2012-09-13 17:09:07 EDT
Yes, that workaround fixes it for me thanks. The test build referenced at https://bugzilla.mozilla.org/show_bug.cgi?id=789726#c11 fixes the problem without the workaround https://bugzilla.mozilla.org/show_bug.cgi?id=779392
Comment 6 Martin Stransky 2012-12-21 08:54:46 EST
https://bugzilla.mozilla.org/show_bug.cgi?id=779392 - It's going to be Fixed in Firefox 19. Let's track it upstream.

Note You need to log in before you can comment on or make changes to this bug.