Bug 854775 - Table cols breaks sandboxing
Table cols breaks sandboxing
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.0
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 19:56 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.27.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:31:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-09-05 19:56:57 EDT
*ERROR: Fatal Table Error* Table (Broker List URL Options) contains invalid data
Attribute cols (2) does not match number of entry elements (XML::Element=HASH(0xaf61378))
 at /usr/share/perl5/Publican/Builder.pm line 467

during publican build.

This occurs if you create a topic with a table with a mismatch between the tgroups col attribute and the number of columns in the row.

Tough one to catch because the <tgroup cols="2"> attribute has to match the number of <entry> elements inside the <row>. 

Doing an xmllint validation using the Docbook DTD doesn't even catch this, so the deathstar editor doesn't get it. 

Ideally this would be sandboxed so that a topic containing a rogue table doesn't break the whole build.


==============================
Generated Details:

CSProcessor client version: 0.26.5

OS: unknown
JAVA: java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-1ubuntu0.12.04.1)
OpenJDK Client VM (build 20.0-b12, mixed mode, sharing)
Comment 1 Lee Newson 2012-09-21 04:28:49 EDT
Fixed in version 0.27.0.

Tables in topics are now validated when building to ensure that table or informaltable have the required number of entry for each row (or td/th for tr rows). Note: You are allowed to have less entries than the value in "cols", but you can't have more.
Comment 2 Lee Newson 2013-06-06 21:31:06 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.