Bug 854910 - qemu-kvm segfault when using VNC
qemu-kvm segfault when using VNC
Status: CLOSED DUPLICATE of bug 851143
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 05:40 EDT by Geert Jansen
Modified: 2013-03-13 02:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 05:49:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geert Jansen 2012-09-06 05:40:13 EDT
I am running RHEL 6.3 with latest errata as a host under RHEV 3.1 beta1. When i use VNC as the display protocol, i get a reliable qemu-kvm crash. The crash happens exactly at the time X11 is started to run Anaconda. Running the VM with a SPICE display works fine.

Versions of relevant packages:

qemu-img-rhev-0.12.1.2-2.295.el6.x86_64
gpxe-roms-qemu-0.9.7-6.9.el6.noarch
qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64
qemu-kvm-rhev-tools-0.12.1.2-2.295.el6.x86_64
vdsm-4.9.6-23.0.el6_3.x86_64
kernel-2.6.32-279.5.2.el6.x86_64

The following messsage appears in /var/log/messages

Sep  6 11:25:58 node1 kernel: qemu-kvm[7816]: segfault at 7f0ac438e010 ip 00007f0acce5ff43 sp 00007fff3c373dd0 error 4 in qemu-kvm[7f0accd65000+277000]

The qemu-kvm command-line is:

qemu      8396  6.3  0.4 1597280 37656 ?       Sl   11:31   0:01 /usr/libexec/qemu-kvm -S -M rhel6.3.0 -cpu Opteron_G3 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name vmrhel63 -uuid e785a299-071f-49a6-8f1c-ed6e44431b1d -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=6Server-6.3.0.3.el6,serial=C048D67B-8DFE-D511-86CC-002354D89D13_00:1B:21:35:62:1E,uuid=e785a299-071f-49a6-8f1c-ed6e44431b1d -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/vmrhel63.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2012-09-06T10:31:15,driftfix=slew -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x4 -drive file=/rhev/data-center/9df3b2b6-f720-11e1-921f-52540038c634/cb7305ad-e941-4c62-92f2-544af0c9cd5a/images/11111111-1111-1111-1111-111111111111/rhel-server-6.3-x86_64-dvd.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=2 -drive file=/rhev/data-center/9df3b2b6-f720-11e1-921f-52540038c634/b4583435-4d6b-4b27-b39a-c48ddbd59113/images/19fefc9f-d211-4937-b9da-52d7a4a12eaa/345bfdcc-d143-43d9-848e-ee80633eb8f4,if=none,id=drive-virtio-disk0,format=raw,serial=19fefc9f-d211-4937-b9da-52d7a4a12eaa,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=26,id=hostnet0,vhost=on,vhostfd=27 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:a8:02:08,bus=pci.0,addr=0x3,bootindex=3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/vmrhel63.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev pty,id=charconsole0 -device virtconsole,chardev=charconsole0,id=console0 -device usb-tablet,id=input0 -vnc 0:0,password -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6

The libvirt XML is:

<domain type='kvm' id='8'>
  <name>vmrhel63</name>
  <uuid>e785a299-071f-49a6-8f1c-ed6e44431b1d</uuid>
  <memory unit='KiB'>1048576</memory>
  <currentMemory unit='KiB'>1048576</currentMemory>
  <vcpu placement='static'>1</vcpu>
  <cputune>
    <shares>1020</shares>
  </cputune>
  <sysinfo type='smbios'>
    <system>
      <entry name='manufacturer'>Red Hat</entry>
      <entry name='product'>RHEV Hypervisor</entry>
      <entry name='version'>6Server-6.3.0.3.el6</entry>
      <entry name='serial'>C048D67B-8DFE-D511-86CC-002354D89D13_00:1B:21:35:62:1E</entry>
      <entry name='uuid'>e785a299-071f-49a6-8f1c-ed6e44431b1d</entry>
    </system>
  </sysinfo>
  <os>
    <type arch='x86_64' machine='rhel6.3.0'>hvm</type>
    <smbios mode='sysinfo'/>
  </os>
  <features>
    <acpi/>
  </features>
  <cpu mode='custom' match='exact'>
    <model fallback='allow'>Opteron_G3</model>
    <topology sockets='1' cores='1' threads='1'/>
  </cpu>
  <clock offset='variable' adjustment='3600'>
    <timer name='rtc' tickpolicy='catchup'/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/rhev/data-center/9df3b2b6-f720-11e1-921f-52540038c634/cb7305ad-e941-4c62-92f2-544af0c9cd5a/images/11111111-1111-1111-1111-111111111111/rhel-server-6.3-x86_64-dvd.iso' startupPolicy='optional'>
        <seclabel relabel='no'/>
      </source>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <serial></serial>
      <boot order='2'/>
      <alias name='ide0-1-0'/>
      <address type='drive' controller='0' bus='1' target='0' unit='0'/>
    </disk>
    <disk type='file' device='disk' snapshot='no'>
      <driver name='qemu' type='raw' cache='none' error_policy='stop' io='threads'/>
      <source file='/rhev/data-center/9df3b2b6-f720-11e1-921f-52540038c634/b4583435-4d6b-4b27-b39a-c48ddbd59113/images/19fefc9f-d211-4937-b9da-52d7a4a12eaa/345bfdcc-d143-43d9-848e-ee80633eb8f4'>
        <seclabel relabel='no'/>
      </source>
      <target dev='vda' bus='virtio'/>
      <serial>19fefc9f-d211-4937-b9da-52d7a4a12eaa</serial>
      <boot order='1'/>
      <alias name='virtio-disk0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </disk>
    <controller type='usb' index='0'>
      <alias name='usb0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
    </controller>
    <controller type='ide' index='0'>
      <alias name='ide0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>
    <controller type='virtio-serial' index='0'>
      <alias name='virtio-serial0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </controller>
    <lease>
      <lockspace>b4583435-4d6b-4b27-b39a-c48ddbd59113</lockspace>
      <key>345bfdcc-d143-43d9-848e-ee80633eb8f4</key>
      <target path='/rhev/data-center/9df3b2b6-f720-11e1-921f-52540038c634/b4583435-4d6b-4b27-b39a-c48ddbd59113/images/19fefc9f-d211-4937-b9da-52d7a4a12eaa/345bfdcc-d143-43d9-848e-ee80633eb8f4.lease'/>
    </lease>
    <interface type='bridge'>
      <mac address='00:1a:4a:a8:02:08'/>
      <source bridge='rhevm'/>
      <target dev='vnet0'/>
      <model type='virtio'/>
      <boot order='3'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>
    <console type='pty' tty='/dev/pts/2'>
      <source path='/dev/pts/2'/>
      <target type='virtio' port='0'/>
      <alias name='console0'/>
    </console>
    <channel type='unix'>
      <source mode='bind' path='/var/lib/libvirt/qemu/channels/vmrhel63.com.redhat.rhevm.vdsm'/>
      <target type='virtio' name='com.redhat.rhevm.vdsm'/>
      <alias name='channel0'/>
      <address type='virtio-serial' controller='0' bus='0' port='1'/>
    </channel>
    <input type='tablet' bus='usb'>
      <alias name='input0'/>
    </input>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5900' autoport='yes' listen='0' keymap='en-us' passwdValidTo='2012-09-06T11:31:25'>
      <listen type='address' address='0'/>
    </graphics>
    <video>
      <model type='qxl' vram='65536' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <memballoon model='virtio'>
      <alias name='balloon0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </memballoon>
  </devices>
  <seclabel type='dynamic' model='selinux' relabel='yes'>
    <label>system_u:system_r:svirt_t:s0:c685,c844</label>
    <imagelabel>system_u:object_r:svirt_image_t:s0:c685,c844</imagelabel>
  </seclabel>
</domain>
Comment 1 Geert Jansen 2012-09-06 05:41:54 EDT
I should add that the guest is RHEL 6.3 which i am trying to install via the install DVD.
Comment 2 Geert Jansen 2012-09-06 05:49:39 EDT

*** This bug has been marked as a duplicate of bug 851143 ***

Note You need to log in before you can comment on or make changes to this bug.