Bug 854916 - [RHSM GUI] Unsubscribe -Traceback- AttributeError:'Backend' object has no attribute 'consumer'.
[RHSM GUI] Unsubscribe -Traceback- AttributeError:'Backend' object has no att...
Status: CLOSED DUPLICATE of bug 851124
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: candlepin-bugs
Entitlement Bugs
: Desktop, i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 05:53 EDT by Lijun Li
Modified: 2012-09-06 22:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 22:58:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unsubscribe -Traceback- AttributeError:'Backend' object has no attribute 'consumer' (58.22 KB, application/octet-stream)
2012-09-06 06:02 EDT, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-09-06 05:53:37 EDT
Description of problem:
Unsubscribe -Traceback- AttributeError:'Backend' object has no attribute 'consumer'.

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.14-1.el5.x86_64.rpm 


How reproducible:
100%

Steps to Reproduce:
1. Install os with latest RHEL5.9 Beta build
2. Run subscription-manager-gui from Terminal
3. Register the system using RHN account and password.
4. Subscribe to a subscription.
5. Unsubscribe from the subscription by clicking 'Unsubscribe' in 'My Subscriptions' tab.
5. Click "Yes" on the "Are you sure..." dialog.
  
Actual results:
Unsubscribe -Traceback- AttributeError:'Backend' object has no attribute 'consumer'.

Expected results:
Should have no traceback and can unsubscribe successfully.

Additional info:
Comment 1 Lijun Li 2012-09-06 05:58:14 EDT
en_US issue, please refer to the attachd screenshot and traceback logs.
Comment 2 Lijun Li 2012-09-06 06:00:49 EDT
[testqa@localhost ~]$ subscription-manager-gui 
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'
Comment 3 Lijun Li 2012-09-06 06:02:11 EDT
Created attachment 610243 [details]
Unsubscribe -Traceback- AttributeError:'Backend' object has no attribute 'consumer'
Comment 4 RHEL Product and Program Management 2012-09-06 06:11:22 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Li Bin Liu 2012-09-06 22:58:40 EDT

*** This bug has been marked as a duplicate of bug 851124 ***

Note You need to log in before you can comment on or make changes to this bug.