Bug 854952 - Start error & problems with workspace
Start error & problems with workspace
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 07:33 EDT by Germano Massullo
Modified: 2012-09-06 07:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 07:59:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Error log (9.07 KB, text/x-log)
2012-09-06 07:33 EDT, Germano Massullo
no flags Details

  None (edit)
Description Germano Massullo 2012-09-06 07:33:28 EDT
Created attachment 610270 [details]
Error log

Description of problem:
Today I opened Eclipse and I got a generic error about the workspace, something about a file that Eclipse could not read. I restarted Eclipse and I got the error message:
An error had occurred. Please check log file at .... /home/...  etc.

Version-Release number of selected component (if applicable):
Eclipse-platform 4.2.0

How reproducible:
Just start Eclipse
Comment 1 Krzysztof Daniel 2012-09-06 07:37:50 EDT
(In reply to comment #0)
> Description of problem:
> Today I opened Eclipse and I got a generic error [...]

What happened yesterday? Any crashes? Software update or installation? Backup tools? 

What about starting eclipse -clean ?
Comment 2 Germano Massullo 2012-09-06 07:50:15 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > Description of problem:
> > Today I opened Eclipse and I got a generic error [...]
> 
> What happened yesterday? Any crashes? Software update or installation?
> Backup tools? 
> 
> What about starting eclipse -clean ?

No crashes yesterday, I only did a yum update that updated a few packages.
eclipse - clean worked. Here is the output:



[caterpillar@computer ~]$ eclipse -clean
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerRendererFilter.showMenu(MenuManagerRendererFilter.java:253)
        at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerRendererFilter.handleShow(MenuManagerRendererFilter.java:225)
        at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerRendererFilter.safeHandleEvent(MenuManagerRendererFilter.java:207)
        at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerRendererFilter.access$1(MenuManagerRendererFilter.java:143)
        at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerRendererFilter$SafeWrapper.run(MenuManagerRendererFilter.java:130)
        at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerRendererFilter.handleEvent(MenuManagerRendererFilter.java:140)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        at org.eclipse.swt.widgets.Display.filterEvent(Display.java:1483)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1275)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1300)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1281)
        at org.eclipse.swt.widgets.Menu._setVisible(Menu.java:198)
        at org.eclipse.swt.widgets.Display.runPopups(Display.java:3596)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3169)
        at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1022)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:916)
        at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:86)
        at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:585)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:540)
        at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:638)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:593)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1447)
Caused by: java.lang.NoClassDefFoundError: org/eclipse/dltk/internal/ui/editor/SourceModuleDocumentProvider
        at org.eclipse.dltk.ui.DLTKUIPlugin.getSourceModuleDocumentProvider(DLTKUIPlugin.java:382)
        at org.eclipse.dltk.ui.DLTKUIPlugin.getWorkingCopyManager(DLTKUIPlugin.java:373)
        at org.eclipse.dltk.internal.ui.ResourceAdapterFactory.getAdapter(ResourceAdapterFactory.java:35)
        at org.eclipse.core.internal.runtime.AdapterManager.getAdapter(AdapterManager.java:326)
        at org.eclipse.core.internal.runtime.AdapterManager.loadAdapter(AdapterManager.java:356)
        at org.eclipse.ui.internal.LegacyResourceSupport.getAdapter(LegacyResourceSupport.java:622)
        at org.eclipse.ui.internal.ObjectActionContributor.isApplicableTo(ObjectActionContributor.java:223)
        at org.eclipse.ui.internal.ObjectContributorManager.isApplicableTo(ObjectContributorManager.java:303)
        at org.eclipse.ui.internal.ObjectActionContributorManager.contributeObjectActions(ObjectActionContributorManager.java:83)
        at org.eclipse.ui.internal.PopupMenuExtender.addObjectActions(PopupMenuExtender.java:316)
        at org.eclipse.ui.internal.PopupMenuExtender.menuAboutToShow(PopupMenuExtender.java:390)
        at org.eclipse.jface.action.MenuManager.fireAboutToShow(MenuManager.java:342)
        at org.eclipse.jface.action.MenuManager.handleAboutToShow(MenuManager.java:473)
        ... 40 more

Note You need to log in before you can comment on or make changes to this bug.