Bug 854956 - [RFE] USBClerk: Doesn't handle auto-redirection of composite USB devices and USB devices with isochronous data transfer
[RFE] USBClerk: Doesn't handle auto-redirection of composite USB devices and ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: usb-clerk-win (Show other bugs)
3.1.0
Unspecified Windows
urgent Severity high
: ---
: ---
Assigned To: Uri Lublin
SPICE QE bug list
spice
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 07:38 EDT by Milan Barta
Modified: 2016-02-10 15:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-19 08:32:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logitech, Inc. ClearChat Pro USB lsusb -v log (12.14 KB, text/plain)
2012-09-06 07:40 EDT, Milan Barta
no flags Details
Lenovo Integrated Webcam [R5U877] lsusb -v log (20.83 KB, text/plain)
2012-09-06 07:41 EDT, Milan Barta
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 318763 None None None Never

  None (edit)
Description Milan Barta 2012-09-06 07:38:36 EDT
Description of problem:
USBClerk is unable to automatically redirect a composite USB devices (eg USB headset) and USB devices with asynchronous data transfer (USB webcam) from Windows client to guest system.

Remote-viewer error message:
"USB redirection error: Could not auto-redirect Logitech, Inc. ClearChat Pro USB [046d:0a0b] at 2-7: Device was not found"

Tested with:
046d:0a0b Logitech, Inc. ClearChat Pro USB
17ef:480f Lenovo Integrated Webcam [R5U877]

Version-Release number of selected component (if applicable):
Client: Windows 7 (64-bit)
Guest: RHEL 6.3

Virt-viewer: 0.5.3
usbclerk-win-0.1-7

How reproducible:
always

Steps to Reproduce:
1. start a windows client with USBClerk service running
2. connect to a USB redirection enabled guest system using virt-viewer (grab focus)
3. connect a composite USB device or asynchronous data transfer device
4. wait for USBClerk to detect the connected device
  
Actual results:
Error message appears, the device is not automatically connected to the guest system.

Expected results:
The device is automatically connected to the guest system.

Additional info:
Comment 1 Milan Barta 2012-09-06 07:40:21 EDT
Created attachment 610278 [details]
Logitech, Inc. ClearChat Pro USB lsusb -v log
Comment 2 Milan Barta 2012-09-06 07:41:18 EDT
Created attachment 610279 [details]
Lenovo Integrated Webcam [R5U877] lsusb -v log
Comment 3 David Blechter 2013-01-18 09:27:35 EST
it is not in a scope of 3.2. Can't commit to 3.2 due to the amount of work it requires, so back to the "future"
Comment 8 David Blechter 2013-05-19 10:10:05 EDT
set the correct flag according to comment #6
Comment 9 David Blechter 2015-08-19 08:32:29 EDT
the features in the bug description are covered in the new Windows USB redir - USBDK that is part of the rhevm 3.6.
Closing the bug

Note You need to log in before you can comment on or make changes to this bug.