Bug 854987 - subscription-manager register for a system fails using the activation key
subscription-manager register for a system fails using the activation key
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Tom McKay
Og Maciel
: Triaged
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-09-06 09:03 EDT by Tom McKay
Modified: 2013-03-27 16:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 854985
Environment:
Last Closed: 2012-12-12 10:20:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-09-06 09:03:18 EDT
+++ This bug was initially created as a clone of Bug #854985 +++

Description of problem:
when registering a system using activation_key 

Version-Release number of selected component (if applicable):
[root@nec-em24-3 ~]# rpm -qa | grep katello
katello-selinux-1.1.1-1.fc16.noarch
katello-configure-1.1.7-1.git.119.b594042.fc16.noarch
katello-common-1.1.9-1.git.128.be134c2.fc16.noarch
katello-cli-common-1.1.5-1.git.129.be134c2.fc16.noarch
katello-glue-pulp-1.1.9-1.git.128.be134c2.fc16.noarch
katello-1.1.9-1.git.128.be134c2.fc16.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.1.8-1.fc16.noarch
katello-glue-foreman-1.1.9-1.git.128.be134c2.fc16.noarch
katello-cli-headpin-1.1.1-1.git.59.e8fe8d3.fc16.noarch
katello-all-1.1.9-1.git.128.be134c2.fc16.noarch
katello-glue-candlepin-1.1.9-1.git.128.be134c2.fc16.noarch
katello-repos-1.1.2-1.fc16.noarch


How reproducible:
yum install -y katello-all thumbslug
katello-configure --deployment=headpin
rpm -ev --nodeps katello-cli
yum install katello-cli-headpin

Steps to Reproduce:
1. [root@nec-em24-3 ~]# subscription-manager register --name "localhost-1346920302" --org "ak-1346920132" --activationkey "act_key-1346920281" --force
Invalid username or password. To create a login, please visit https://www.redhat.com/wapps/ugc/register.html


  
Actual results:
system is not registered

Expected results:

system should be registered 
Additional info:
Comment 1 Tom McKay 2012-09-10 08:15:48 EDT
Confirmed by original reporter as not a bug.
Comment 2 James Laska 2012-12-12 10:20:57 EST
CLOSED NOTABUG based on comment#1

Note You need to log in before you can comment on or make changes to this bug.