This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 855020 - db-control shrink-segments after upgrade DB
db-control shrink-segments after upgrade DB
Status: CLOSED DUPLICATE of bug 918045
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
550
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: 819027 918045
  Show dependency treegraph
 
Reported: 2012-09-06 10:18 EDT by Martin Korbel
Modified: 2013-07-08 11:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 918045 (view as bug list)
Environment:
Last Closed: 2013-07-08 11:32:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Korbel 2012-09-06 10:18:15 EDT
I have got this error message on upgraded system (Sat5.3 RHEL4 -> Sat5.5 RHEL6). I tried this command "db-control shrink-segments" after each step restore DB, /usr/share/spacewalk/setup/oracle/upgrade-db.sh and /usr/bin/spacewalk-schema-upgrade (all these commands finished OK) and I got different errors (with same file and number line /usr/share/perl5/vendor_perl/Dobby/DB.pm line 262).

bash-4.1$ db-control shrink-segments
Running segment advisor to find out shrinkable segments...
WARNING: this may be a slow process.
Shrinking recomended segments...
RHN_PKG_CL_PID_N_TXT_TIME_UQ      233.4M reclaimable
DBD::Oracle::db do failed: ORA-30036: unable to extend segment by 8 in undo tablespace 'UNDO_TBS' (DBD ERROR: OCIStmtExecute) [for Statement "alter index "RHNSAT"."RHN_PKG_CL_PID_N_TXT_TIME_UQ" shrink space COMPACT"] at /usr/share/perl5/vendor_perl/Dobby/DB.pm line 262.

....

DBD::Oracle::db do failed: ORA-00942: table or view does not exist (DBD ERROR: OCIStmtExecute) [for Statement "alter table "RHNSAT"."RHNPACKAGECHANGELOG" shrink space COMPACT"] at /usr/share/perl5/vendor_perl/Dobby/DB.pm line 262.

....

DBD::Oracle::db do failed: ORA-01418: specified index does not exist (DBD ERROR: OCIStmtExecute) [for Statement "alter index "RHNSAT"."RHN_PKG_CL_PID_N_TXT_TIME_UQ" shrink space COMPACT"] at /usr/share/perl5/vendor_perl/Dobby/DB.pm line 262.



INFO:
-bash-4.1$ db-control report 
Tablespace                  Size    Used   Avail   Use%
DATA_TBS                    4.3G    1.9G    2.4G    44%
SYSAUX                      500M  108.4M  391.5M    22%
SYSTEM                      400M  261.3M  138.6M    65%
TEMP_TBS                   1000M      0B   1000M     0%
UNDO_TBS                    1.9G  425.7M    1.5G    21%
USERS                       128M     64K  127.9M     0%
Comment 7 Clifford Perry 2013-07-08 11:32:10 EDT

*** This bug has been marked as a duplicate of bug 918045 ***

Note You need to log in before you can comment on or make changes to this bug.