Bug 855027 - [abrt] yumex-3.0.6-1.fc18: yum_backend.py:182:yum_dnl_progress:ValueError: too many values to unpack
[abrt] yumex-3.0.6-1.fc18: yum_backend.py:182:yum_dnl_progress:ValueError: to...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
abrt_hash:add5a6e397294e094deb9e89d93...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 10:30 EDT by Bharat Parekh
Modified: 2012-09-17 18:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:20:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.08 KB, text/plain)
2012-09-06 10:30 EDT, Bharat Parekh
no flags Details

  None (edit)
Description Bharat Parekh 2012-09-06 10:30:57 EDT
Version-Release number of selected component:
yumex-3.0.6-1.fc18

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python -tt /usr/bin/yumex
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64

backtrace:
:yum_backend.py:182:yum_dnl_progress:ValueError: too many values to unpack
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 1326, in on_packageFilter_changed
:    pkgs = self.backend.get_packages(active)
:  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_backend.py", line 355, in get_packages
:    pkgs = YumClient.get_packages(self, flt, show_dupes)
:  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_client.py", line 586, in get_packages
:    return self.execute_command('get-packages', [str(pkg_filter), str(show_dupes)])
:  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_client.py", line 543, in execute_command
:    pkgs = self._get_list()
:  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_client.py", line 420, in _get_list
:    cmd, args = self._readline()
:  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_client.py", line 308, in _readline
:    if self._check_for_message(cmd, args):
:  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_client.py", line 351, in _check_for_message
:    self._yum_dnl(args[0])
:  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_client.py", line 103, in _yum_dnl
:    self.yum_dnl_progress(ftype, name, percent, cur, tot, fread, ftotal, ftime)
:  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_backend.py", line 182, in yum_dnl_progress
:    repo, mdtype = name.split('/')
:ValueError: too many values to unpack
:
:Local variables in innermost frame:
:cur: 1
:self: <yumexbackend.yum_backend.YumexBackendYum object at 0x1419d90>
:fread: ''
:percent: 0
:tot: 1
:ftotal: '1.2 k'
:ftype: 'REPO'
:ftime: ''
:progress: <yumexgui.dialogs.Progress instance at 0x1402830>
:name: 'rpmfusion-free-updates/18/x86_64/primary'
Comment 1 Bharat Parekh 2012-09-06 10:30:59 EDT
Created attachment 610353 [details]
File: core_backtrace
Comment 2 Tim Lauridsen 2012-09-07 00:41:41 EDT
I can reproduce this in F18 sometimes.

Look like something is changed in the way yum return the names when downloading metadata files.
Comment 4 Tim Lauridsen 2012-09-08 03:29:46 EDT
test build rpms available here:

http://timlau.fedorapeople.org/files/yumex/

With the fix included
Comment 5 Fedora Update System 2012-09-12 07:40:57 EDT
yumex-3.0.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yumex-3.0.7-1.fc18
Comment 6 Fedora Update System 2012-09-12 15:15:12 EDT
Package yumex-3.0.7-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-3.0.7-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13885/yumex-3.0.7-1.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-09-17 18:20:50 EDT
yumex-3.0.7-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.