Bug 855101 - Replace highcharts in foreman before release
Replace highcharts in foreman before release
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
urgent Severity high (vote)
: Unspecified
: --
Assigned To: Sam Kottler
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 13:02 EDT by Miroslav Suchý
Modified: 2014-06-18 04:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-05 09:26:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2012-09-06 13:02:30 EDT
Foreman bundle into its code ./public/javascripts/highcharts.js

This is not free code. And has to bee replaced before we do release. See:
www.highcharts.com/license
Comment 1 Sam Kottler 2012-09-06 13:47:39 EDT
This is something we've spoken about before. I will take some time in the next few days to put together a list of potential replacements for the Foreman and Katello teams to review.
Comment 3 Miroslav Suchý 2013-07-04 08:51:30 EDT
This seems to be resolved by 870e7fcc86322c5d332fef028fa68728d410208c in foreman.git

Note You need to log in before you can comment on or make changes to this bug.