Bug 855110 - Offset between mouse pointer and cursor when guest has two qxl devices emulated.
Offset between mouse pointer and cursor when guest has two qxl devices emulated.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-vdagent (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Hans de Goede
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 13:57 EDT by Marian Krcmarik
Modified: 2013-07-03 08:05 EDT (History)
5 users (show)

See Also:
Fixed In Version: spice-vdagent-0.12.0-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:23:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
packet capture (4.94 MB, application/x-pcap)
2012-09-24 05:26 EDT, David Jaša
no flags Details

  None (edit)
Description Marian Krcmarik 2012-09-06 13:57:35 EDT
Description of problem:
There is an offset between mouse pointer and actually displayed cursor on RHEL guest when qemu has two qxl devices assigned - simply Clicks are being made somewhere else from position of cursor.
This does not happen on the same setup with spice-vdagent downgraded to 0.8.1-3 version shipped in RHEL6.3.
Note: Second screen is not actived - Xinerama is not used.

Version-Release number of selected component (if applicable):
spice-vdagent-0.12.0-1
spice-gtk-0.13.29-1
spice-server-0.11.3-1 - test package
virt-viewer-0.5.2-10

How reproducible:
Always

Steps to Reproduce:
1. Start a RHEL6 guest with two QXL devices (Do not use Xinerama or anything to activate second screen).
2. Open Spice session to the guest with remote-viewer
3. Click anywhere.
  
Actual results:
Click is made on different place from place where cursor points.

Expected results:
Pointer and cursor should be synced.

Additional info:
Comment 2 David Jaša 2012-09-24 05:26:45 EDT
Created attachment 616439 [details]
packet capture

Adding a packet catpure of the problem.
Comment 3 Hans de Goede 2012-10-10 05:13:57 EDT
Thanks for the report, this is fixed by the latest 2 upstream commits:
http://cgit.freedesktop.org/spice/linux/vd_agent/log/

Adding devel-ack and moving to POST.
Comment 5 Hans de Goede 2012-10-14 09:00:39 EDT
This is fixed in spice-vdagent-0.12.0-2.el6 moving to modified.
Comment 9 errata-xmlrpc 2013-02-21 03:23:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0311.html

Note You need to log in before you can comment on or make changes to this bug.