Bug 855226 - [Opensource Console]Caught "ArgumentError in AccountController#show " error when trying to access the my account page after creating domain name.
[Opensource Console]Caught "ArgumentError in AccountController#show " error w...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
: 855242 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 23:40 EDT by Yujie Zhang
Modified: 2015-05-14 21:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Site and Broker detail logs. (3.07 KB, text/plain)
2012-09-06 23:40 EDT, Yujie Zhang
no flags Details

  None (edit)
Description Yujie Zhang 2012-09-06 23:40:26 EDT
Created attachment 610599 [details]
Site and Broker detail logs.

Description of problem:

After I created domain name, I tried to access my account page, and caught "ArgumentError in AccountController#show" error, and it also will happen when I am creating domain name,but the error will disappear in about 5 minutes if I keep refreshing the page.Detais log please see in attachment.

Version-Release number of selected component (if applicable):

fork_ami_opensource_console_rails32_87

How reproducible:always


Steps to Reproduce:
1.Go to openshift website 
2.Create a domain name
3.Go to my account page again
  
Actual results:

Caught "ArgumentError in AccountController#show " error when trying to access the my account page after creating domain name.

Expected results:

Should not catch the above error.

Additional info:
Comment 1 Clayton Coleman 2012-09-07 14:05:08 EDT
This is related to cache reading.  I need to implement a deserialization strategy that still works.
Comment 2 Clayton Coleman 2012-09-07 14:05:20 EDT
*** Bug 855242 has been marked as a duplicate of this bug. ***
Comment 3 Clayton Coleman 2012-09-07 16:32:44 EDT
Fixed in https://ci.dev.openshift.redhat.com/jenkins/job/fork_ami/95/ in commit 

[rails32 328f383] Bug 855226 - Cached resources cannot be reloaded in Rails 3.2, need to check for ArgumentError and retry the request if so.
Comment 4 Xiaoli Tian 2012-09-13 04:20:28 EDT
Move it back to ON_DEV since there's no such an fork_ami ready for testing.
Comment 5 Xiaoli Tian 2012-09-13 06:56:13 EDT
Move its severity to low since this does not affect current console
Comment 6 Clayton Coleman 2012-09-26 15:29:10 EDT
This should be in fork_ami_opensource_console_final_144 or greater
Comment 7 Yujie Zhang 2012-09-27 05:56:50 EDT
(In reply to comment #6)
Tested this issue on devenv_2440, it has been fixed now, thanks.

Note You need to log in before you can comment on or make changes to this bug.