Bug 855234 - "d3N1bkByZWRoYXQuY29tOn JlZGhhdA==" is diaplayed when using rhc domain show or rhc domain create
"d3N1bkByZWRoYXQuY29tOn JlZGhhdA==" is diaplayed when using rhc domain show ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 00:22 EDT by Wei Sun
Modified: 2015-05-14 22:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.98.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2012-09-07 00:22:56 EDT
Description of problem:
When use command: rhc domain show or rhc domain create,like "d3N1bkByZWRoYXQuY29tOn JlZGhhdA==" information

Version-Release number of selected component (if applicable):
rhc 0.98.9
devenv_2128

How reproducible:
always

Steps to Reproduce:
1.rhc domain show -p redhat
2.rhc domain create
3.
  
Actual results:
openshift@openshift-ubuntu:~/test/dev$ rhc domain show -p redhat
d3N1bkByZWRoYXQuY29tOn
JlZGhhdA==

Applications in wsundevful907:

phptest @ http://phptest-wsundevful907.dev.rhcloud.com/
=======================================================
Created: 11:37 PM
Git URL: ssh://f54f03d22c26408f8e7d954cb2fa313d@phptest-wsundevful907.dev.rhcloud.com/~/git/phptest.git/

Cartridges:
  php-5.3



openshift@openshift-ubuntu:~$ rhc domain create wsundevful907 -d -p redhat 

Creating domain with namespace 'wsundevful907'

D, [2012-09-06T23:30:38.960036 #23378] DEBUG -- : Connecting to https://ec2-23-22-0-170.compute-1.amazonaws.com/broker/rest/api
d3N1bkByZWRoYXQuY29tOn
JlZGhhdA==
D, [2012-09-06T23:30:41.544252 #23378] DEBUG -- : Adding domain wsundevful907
RESULT:
Success!
You may now create an application using the 'rhc app create' command

Expected results:
don't show this information

Additional info:

this bug can be found on ubuntu and rhel6,but can not be found on fedora17
Comment 1 John (J5) Palmieri 2012-09-07 01:02:25 EDT
Looks like the base64 user:password creds sent during connection.  I don't see this issue on fedora17.  I'm guessing this is a ruby 1.8 issue and that perhaps b64encode may print to stdout for some reason.  I don't see any stray puts in recently checked in code.
Comment 2 John (J5) Palmieri 2012-09-07 01:06:19 EDT
I can confirm that this is what is happening.
Comment 3 joycezhang 2012-09-07 01:11:14 EDT
The bug is also reproduced when using following command:
1. rhc domain update:
# rhc domain update joycedev4
Password: *

amluemhhbmcrNUByZWRoYXQ
uY29tOmE=
Changing namespace 'joycedev5' to 'joycedev4'...

2. rhc domain delete:
# rhc domain delete joycedev4
Password: *

amluemhhbmcrNUByZWRoYXQ
uY29tOmE=
Deleting domain 'joycedev4'

3. Create scalable app:
# rhc app create -a myscapp3 -t python-2.6 -s
Password: *

Creating application: myscapp3 in joycedev4
amluemhhbmcrNUByZWRoYXQ
uY29tOmE=

Thanks
Comment 4 John (J5) Palmieri 2012-09-07 01:20:10 EDT
It will show up whenever using the rest modules during authentication.  Merging fix now.
Comment 5 Wei Sun 2012-09-07 06:33:00 EDT
This bug is reproduced on ruby-1.8
Comment 6 Wei Sun 2012-09-09 22:04:10 EDT
verified on rhc-0.98.10
devenv_2140
ruby 1.8


1.rhc domain show

openshift@openshift-ubuntu:~$ rhc domain show
Password: ******

No domain exists.  You can use 'rhc domain create' to create a namespace for applications.

2.rhc domain create

openshift@openshift-ubuntu:~/test/dev$ rhc domain create -n wsunint910 

Creating domain with namespace 'wsunint910'

Password: ******

RESULT:
Success!
You may now create an application using the 'rhc app create' command

3.create a scalable app:
openshift@openshift-ubuntu:~/test/dev$ rhc app create -a phps -t php-5.3 -s -n 
Password: ******

Creating application: phps in wsunint910
Now your new domain name is being propagated worldwide (this might take a minute)...

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
IMPORTANT: Since the -n flag was specified, no local repo has been created.
This means you can't make changes to your published application until after
you clone the repo yourself.  See the git url below for more information.
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Checking if the application is available #1
Application phps is available at: http://phps-wsunint910.dev.rhcloud.com/
  Git URL: ssh://92c92e0a483e4428a99f1387700d337b@phps-wsunint910.dev.rhcloud.com/~/git/phps.git/
Successfully created application: phps

4.rhc domain update

openshift@openshift-ubuntu:~/test/dev$ rhc domain update -n wsundev910
Password: ******

Changing namespace 'wsunint910' to 'wsundev910'...

RESULT:
Success!
You can use 'rhc domain show' to view any url changes.  Be sure to update any links including the url in your local git config: <local_git_repo>/.git/config

5.rhc domain delete
openshift@openshift-ubuntu:~/test/dev$ rhc domain delete -n wsundev910
Password: ******

Deleting domain 'wsundev910'

RESULT:
Success!

Note You need to log in before you can comment on or make changes to this bug.