Bug 855244 - Addition of Posix Compliant FS storage type always stays in progress
Addition of Posix Compliant FS storage type always stays in progress
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Linux
unspecified Severity urgent
: ---
: 3.1.0
Assigned To: Tal Nisan
vvyazmin@redhat.com
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 01:53 EDT by Anush Shetty
Modified: 2016-02-10 14:49 EST (History)
11 users (show)

See Also:
Fixed In Version: SI21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log. (151.70 KB, application/x-gzip)
2012-09-11 07:50 EDT, Haim
no flags Details

  None (edit)
Description Anush Shetty 2012-09-07 01:53:09 EDT
Description of problem: After adding a new storage domain in RHEVM for Posix compliant FS, the dialog box stays in progress forever.

Version-Release number of selected component (if applicable):

rhevm-webadmin-portal-3.1.0-15.el6ev.noarch
glusterfs-3.3.0rhsvirt1-2.el6_2.x86_64


How reproducible: Consistently


Steps to Reproduce:
1. gluster volume create distribute-replicate-2x2 rhs-gp-srv11.lab.eng.blr.redhat.com:/disk1 rhs-gp-srv12.lab.eng.blr.redhat.com:/disk1 rhs-gp-srv15.lab.eng.blr.redhat.com:/disk1 rhs-gp-srv4.lab.eng.blr.redhat.com:/disk1
2. gluster volume start distribute-replicate-2x2
3. From RHEVM, create a new storage domain with VFS type glusterfs and mount path as rhs-gp-srv11.lab.eng.blr.redhat.com:/distribute-replicate-2x2
  
Actual results:

After clicking ok, the dialog stays in process and never shows it as complete.

Expected results:

Should successfully add the storage.

Additional info:

In the backend, the storage domain was mounted successfully but from RHEVM, it stayed in progress.

In the ovirt-engine log:
2012-09-07 01:43:20,248 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ValidateStorageServerConnectionVDSCommand] (ajp-/127.0.0.1:8009-3) [1f2ff827] START, ValidateStorageServerConnectionVDSCommand(vdsId = 940b52fe-f68f-11e1-8ce4-52540035ed48, storagePoolId = 00000000-0000-0000-0000-000000000000, storageType = POSIXFS, connectionList = [{ id: null, connection: rhs-gp-srv11.lab.eng.blr.redhat.com:/distribute-replicate-2x2, iqn: null, vfsType: glusterfs, mountOptions: null, nfsVersion: null, nfsRetrans: null, nfsTimeo: null };]), log id: f684934
2012-09-07 01:43:20,269 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ValidateStorageServerConnectionVDSCommand] (ajp-/127.0.0.1:8009-3) [1f2ff827] FINISH, ValidateStorageServerConnectionVDSCommand, return: {00000000-0000-0000-0000-000000000000=0}, log id: f684934
2012-09-07 01:43:20,273 INFO  [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-/127.0.0.1:8009-3) [1f2ff827] Running command: AddStorageServerConnectionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: System
2012-09-07 01:43:20,274 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (ajp-/127.0.0.1:8009-3) [1f2ff827] START, ConnectStorageServerVDSCommand(vdsId = 940b52fe-f68f-11e1-8ce4-52540035ed48, storagePoolId = 00000000-0000-0000-0000-000000000000, storageType = POSIXFS, connectionList = [{ id: 9b22ca14-55a0-4245-9136-6ff551656150, connection: rhs-gp-srv11.lab.eng.blr.redhat.com:/distribute-replicate-2x2, iqn: null, vfsType: glusterfs, mountOptions: null, nfsVersion: null, nfsRetrans: null, nfsTimeo: null };]), log id: 17ed6c69
2012-09-07 01:43:24,369 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (ajp-/127.0.0.1:8009-3) [1f2ff827] FINISH, ConnectStorageServerVDSCommand, return: {9b22ca14-55a0-4245-9136-6ff551656150=0}, log id: 17ed6c69
2012-09-07 01:43:24,394 WARN  [org.ovirt.engine.core.dal.job.ExecutionMessageDirector] (ajp-/127.0.0.1:8009-7) [7d415f0] The message key AddPosixFsStorageDomain is missing from bundles/ExecutionMessages
2012-09-07 01:43:24,406 INFO  [org.ovirt.engine.core.bll.storage.AddPosixFsStorageDomainCommand] (ajp-/127.0.0.1:8009-7) [7d415f0] Running command: AddPosixFsStorageDomainCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: System
2012-09-07 01:43:24,413 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStorageDomainVDSCommand] (ajp-/127.0.0.1:8009-7) [7d415f0] START, CreateStorageDomainVDSCommand(vdsId = 940b52fe-f68f-11e1-8ce4-52540035ed48, storageDomain=org.ovirt.engine.core.common.businessentities.storage_domain_static@e92bf4dc, args=rhs-gp-srv11.lab.eng.blr.redhat.com:/distribute-replicate-2x2), log id: 102ad259
2012-09-07 01:43:27,128 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStorageDomainVDSCommand] (ajp-/127.0.0.1:8009-7) [7d415f0] FINISH, CreateStorageDomainVDSCommand, log id: 102ad259
2012-09-07 01:43:27,131 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetStorageDomainStatsVDSCommand] (ajp-/127.0.0.1:8009-7) [7d415f0] START, GetStorageDomainStatsVDSCommand(vdsId = 940b52fe-f68f-11e1-8ce4-52540035ed48, storageDomainId=62bebb34-33c1-4329-9b69-e88dda3dc482), log id: 2e8f1154
2012-09-07 01:43:27,159 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetStorageDomainStatsVDSCommand] (ajp-/127.0.0.1:8009-7) [7d415f0] FINISH, GetStorageDomainStatsVDSCommand, return: org.ovirt.engine.core.common.businessentities.storage_domains@43c4daa, log id: 2e8f1154
2012-09-07 01:45:00,001 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-98) Autorecovering hosts is disabled, skipping
2012-09-07 01:45:00,001 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-98) Autorecovering storage domains is disabled, skipping
2012-09-07 01:50:00,000 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-100) Autorecovering hosts is disabled, skipping
2012-09-07 01:50:00,001 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-100) Autorecovering storage domains is disabled, skipping
(END)
Comment 4 Haim 2012-09-11 07:34:22 EDT
so I manage to reproduce, it looks like a web-admin issue since command succeed on both engine and vdsm, GUI stuck on hour glass for good.
need to close my session to web-admin, and re-open, later I see that that domain was created and i was able to attach it to pool.
Comment 5 Haim 2012-09-11 07:50:31 EDT
Created attachment 611740 [details]
engine log.
Comment 6 Allon Mureinik 2012-10-11 05:59:57 EDT
Merged I0512ee572069330fcc748e3d078702836dc9b446

Note You need to log in before you can comment on or make changes to this bug.