Bug 855279 - [RFE] add "description" field in "product status" CLI output.
[RFE] add "description" field in "product status" CLI output.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Dustin Tsang
sthirugn@redhat.com
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 04:04 EDT by Hayk Hovsepyan
Modified: 2016-04-22 11:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-11 08:25:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6345 None None None 2016-04-22 11:11 EDT

  None (edit)
Description Hayk Hovsepyan 2012-09-07 04:04:03 EDT
Description of problem:
In "product" CLI currently is is possible to update "description", but it is not possible to view it.
It needs to add "description" field in output of "product status" CLI command.
This is the only command which shows info about product.
Comment 1 Bryan Kearney 2014-05-23 15:27:54 EDT
This is still busted.

[root@sat6 checks]# hammer -v --username admin --password changeme product list --organization-label "DemoOrg"
---|--------------------------------|------------------|--------------|-----------
ID | NAME                           | ORGANIZATION     | REPOSITORIES | SYNC STATE
---|--------------------------------|------------------|--------------|-----------
10 | BK Product of Fun              | Anakin Skywalker | 0            | not_synced
1  | Red Hat Satellite Tools 6 Beta | Anakin Skywalker | 0            | not_synced
---|--------------------------------|------------------|--------------|-----------
[root@sat6 checks]# hammer -v --username admin --password changeme product info --organization-label "DemoOrg" --id 10
ID:           10
Name:         BK Product of Fun
Label:        BK_Product_of_Fun
Description:  
Sync State:   not_synced
Sync Plan ID: 
GPG:          
    GPG Key ID: 
    GPG Key:
Organization: Anakin Skywalker
Readonly:     false
Deletable:    true
Content:      
 1) Repo Name: 
    URL:

[root@sat6 checks]#
Comment 2 Dustin Tsang 2014-06-23 13:06:53 EDT
redmine issue created
Comment 3 Bryan Kearney 2014-06-23 14:01:14 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/6345 has been closed
Comment 4 Dustin Tsang 2014-06-24 11:17:33 EDT
accidentally set to closed in redmine...moving back to assigned.
Comment 5 Bryan Kearney 2014-06-24 12:01:10 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/6345 has been closed
Comment 7 sthirugn@redhat.com 2014-09-04 12:35:43 EDT
Verified.

hammer> product info --id=92
ID:           92
Name:         puppetproduct1
Label:        puppetproduct1
Description:  testdesc
Sync State:   finished
Sync Plan ID: 
GPG:          
    GPG Key ID: 
    GPG Key:
Organization: rhcorp
Readonly:     false
Deletable:    
Content:      
 1) Repo Name: puppetrepo1
    URL:       /custom/puppetproduct1/puppetrepo1
 2) Repo Name: puppetforge
    URL:       /custom/puppetproduct1/puppetforge
 3) Repo Name: newpuppetrepo
    URL:       /custom/puppetproduct1/newpuppetrepo

Version Tested:
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140829.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
Comment 8 Bryan Kearney 2014-09-11 08:25:24 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.