Bug 855338 - Restarting "libra" service fails to restart apps
Restarting "libra" service fails to restart apps
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 08:54 EDT by jizhao
Modified: 2015-05-14 18:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ramr: needinfo+


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-09-07 08:54:58 EDT
Description of problem:
Run "service libra restart" on the server. Get error message "runcon: invalid context: unconfined_u:unconfined_r:libra_t:s0:c0,c506: Invalid argument". The apps' pid don't change.

Version-Release number of selected component (if applicable):
devenv_2129

How reproducible:
Always

Steps to Reproduce:
1.SSH login the server
2.service libra restart
3.Check app's pid
  
Actual results:
It fails to restart apps.
<-----------------------output------------------------->
Stopping 44fe652a4abf40169570d9ad3e79f8e3...
    mongophoujw38_ctl.sh                                   runcon: invalid context: unconfined_u:unconfined_r:libra_t:s0:c0,c503: Invalid argument
[  OK  ]
Starting 44fe652a4abf40169570d9ad3e79f8e3...
    mongophoujw38_ctl.sh                                   runcon: invalid context: unconfined_u:unconfined_r:libra_t:s0:c0,c503: Invalid argument
[  OK  ]
<------------------------------------------------------>
The pid remains the same.

Expected results:
The app should be restarted successfully. The pid should change.

Additional info:
Comment 1 Ram Ranganathan 2012-09-07 14:39:36 EDT
@jizhao, it works for me -- did you stop and restart the node per chance?? 
You'd need to run rhc-restorecon I think in that case. 

Also, if you create a new app, does that work?? 

And could you please attach the uid value (from /etc/passwd) for  gear. 44fe652a4abf40169570d9ad3e79f8e3  and  a ls -altrZ on the mongodb-2.0 
directory in the gear.

Thanks.
Comment 2 jizhao 2012-09-10 05:41:46 EDT
I created a clean devenv_2140 instance and tried again. It worked.
It seems some automation scripts broke the SELinux lable. I'll fix them.

Note You need to log in before you can comment on or make changes to this bug.