Bug 855371 - anaconda doesn't handle correctly the method=cdrom command line parameter
anaconda doesn't handle correctly the method=cdrom command line parameter
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Installation_Guide (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Bokoc
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 10:26 EDT by Olivier BONHOMME
Modified: 2013-10-02 09:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 09:33:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier BONHOMME 2012-09-07 10:26:15 EDT
Description of problem:

The anaconda documentation says that it is possible to use the cdrom value for the method parameter in the kernel command line when we want to make a RHEL installation.

However if we set method=cdrom on the kernel command line, it seems that anaconda doesn't handle it correctly since the loader display the installation method window.

After looking in the code, I discovered on the loader2/method.c file (line 739) that the string comparison is done with the 'cdrom:' and not only on 'cdrom'.

If on my kernel command line i put method=cdrom:, anaconda detects automatically the install method and doesn't display the 'Installation method' anymore. 

Moreover in the anaconda code, the comparison is done against the string 'cdrom://'.

So I conclude, there is a mismatch between the documentation and the way anaconda parses the method parameter.

Version-Release number of selected component (if applicable): 11.1.2.250-1

How reproducible: Try to make an automated installation with a kickstart configured without the cdrom parameter and the kernel parameter method=cdrom

Steps to Reproduce:
1.Having a kickstart file without the cdrom parameter
2.Declare a kernel command line with method=cdrom
  
Actual results: The loader binary asks for the Installation method because it couldn't parse the method parameter.

Expected results:The loader binary shouldn't ask for the Installation Method.
Comment 2 Jack Reed 2013-04-23 19:51:54 EDT
Thanks for catching this, Olivier. I've edited the listing for the cdrom parameter so it now reads 'method=cdrom://'

You'll find this update in the 5.10 documentation.
Comment 6 RHEL Product and Program Management 2013-05-01 18:09:05 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.