Bug 855413 - Improve handling of the symlinks during IPA upgrades
Improve handling of the symlinks during IPA upgrades
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 12:33 EDT by Dmitri Pal
Modified: 2012-09-19 15:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 15:36:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-09-07 12:33:22 EDT
Summary:

There is an issue with the symlinks to jars during upgrade from different versions
Alexander Bokovoy did fix this for Fedora with F16 release in past -- in /usr/libexec/freeipa-systemd-update in Fedora packages there is an elaborate code to handle these updates of the symlinks.
We need to extract that part and add to RHEL6.

For more details see mail thread: 
https://www.redhat.com/archives/freeipa-users/2012-September/msg00006.html
Comment 1 Dmitri Pal 2012-09-07 12:34:42 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3061
Comment 3 Jenny Galipeau 2012-09-11 13:38:52 EDT
Please add steps to reproduce / verify ... this is very confusing as that systemd is not yet in RHEL?
Comment 5 Rob Crittenden 2012-09-13 10:52:22 EDT
This is not an IPA problem, we simply recognize it during upgrade and attempt to fix it in Fedora (when we fix other things, such as converting from SysV to systemd).

The problem seems to be that on 64-bit platforms the symlink for jss was in /usr/lib and not in /usr/lib64 and this caused dogtag to not start.

I think this bug should be re-pointed to either dogtag or jss and should not be fixed by IPA.
Comment 6 Dmitri Pal 2012-09-19 15:36:12 EDT
As it is not an IPA problem I am closing this BZ.
Other BZs will be open against the corresponding java packages that cause the problem in the first place.

Note You need to log in before you can comment on or make changes to this bug.