Bug 855474 - svn mkdir --parents generates extraneous directories when the targets already exist.
svn mkdir --parents generates extraneous directories when the targets already...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subversion (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Joe Orton
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 19:02 EDT by Trevin Beattie
Modified: 2017-10-17 03:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-17 03:54:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shell script which runs "svn mkdir --parents" with three nested directories (339 bytes, application/x-shellscript)
2012-09-07 19:02 EDT, Trevin Beattie
no flags Details
Access log from the subversion server (17.66 KB, text/plain)
2012-09-07 19:07 EDT, Trevin Beattie
no flags Details

  None (edit)
Description Trevin Beattie 2012-09-07 19:02:35 EDT
Created attachment 610856 [details]
Shell script which runs "svn mkdir --parents" with three nested directories

Description of problem:
I noticed this when writing an application with the Perl bindings, and later confirmed it when using the command-line client with similar options.  If I use the --parents option when creating multiple directories in a subversion repository, and those directories already exist, the client generates additional directories that were not in the request.  For example, a repeated request to create "test/one", "test/one/two", and "test/one/two/three" results in creating "test/one/two/one/two/three".

Version-Release number of selected component (if applicable):
1.6.11-7.el6; also seen in 1.6.11-10.el5_8

How reproducible:
Always (provided one starts with a non-existent parent directory).

Steps to Reproduce:
1. Run the attached shell script, giving in the URL of a new directory in a subversion repository.
2. Run the script again with the same URL.
  
Actual results:
It creates the child directories one/two/one/two/three.

Expected results:
Should have returned an error "405 Method Not Allowed".

Additional info:
I will also be adding the access logs from the subversion server which show the client sending requests to create directories that it shouldn't.
Comment 1 Trevin Beattie 2012-09-07 19:07:09 EDT
Created attachment 610858 [details]
Access log from the subversion server

The log entries from the first time I ran the shell script have a time stamp of 07/Sep/2012:13:38:32-38:42.  The second time I ran the shell script was at 07/Sep/2012:13:38:51-38:57.
Comment 3 RHEL Product and Program Management 2013-10-13 20:28:19 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Red Hat Bugzilla Rules Engine 2017-10-17 03:54:23 EDT
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.