Bug 855579 - [admin-portal] Run once: unable to attach floppy disks (*.vfd extension is filtered out)
[admin-portal] Run once: unable to attach floppy disks (*.vfd extension is fi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Tomas Jelinek
Pavel Stehlik
virt
: Regression, TestBlocker
: 863664 870124 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 01:33 EDT by Haim
Modified: 2014-01-12 19:54 EST (History)
11 users (show)

See Also:
Fixed In Version: si20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of iso_list (94.86 KB, image/png)
2012-09-09 01:35 EDT, Haim
no flags Details

  None (edit)
Description Haim 2012-09-09 01:33:53 EDT
Description of problem:

1) create vm 
2) right click - chose 'run once'
3) click both 'floppy' and 'attach cd'
4) ISO list appears on both dialogues
Comment 1 Haim 2012-09-09 01:35:06 EDT
Created attachment 611151 [details]
screen shot of iso_list
Comment 2 Haim 2012-09-09 01:56:13 EDT
its serious then I thought, it appears as if *.vfd file extention is filtered out from attach floppy dialogue, its a web-admin issue since both vdsm and engine returns floppy list:


2012-09-09 11:38:58,789 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetFloppyListVDSCommand] (pool-4-thread-49) [26b80477] START, GetFloppyListVDSCommand(storagePoolId = fc75bbba-f755-11e1-8adb-001a4a16970e, ignoreFailoverLimit = false, compatabilityVersion = null), log id: 1310c11c
2012-09-09 11:38:58,853 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetFloppyListVDSCommand] (pool-4-thread-49) [26b80477] FINISH, GetFloppyListVDSCommand, return: [win2k3-32-with-virtio.vfd, win2k8-32_with_virtio.vfd, win7-32_with_virtio.vfd, virtio-drivers-1.0.0-45801.vfd, win2003-x64-unattended.vfd, win2k3.vfd, win2k8-R2.vfd, win2003-32-unattended.vfd, win2k3x64.vfd, virtio-win-1.4.0.vfd, win2000-Pro-unattended.vfd, win7-32.vfd, virtio-drivers.vfd, win7-64.vfd, virtio-drivers-1.0.0-8.vfd, virtio-win-1.1.16.vfd, win2k3-64-with-virtio.vfd, win7x64_with_virtio.vfd, win2k8-R2_with_virtio.vfd], log id: 1310c11c


Thread-13739::INFO::2012-09-09 08:37:48,242::logUtils::37::dispatcher::(wrapper) Run and protect: getFloppyList(spUUID='fc75bbba-f755-11e1-8adb-001a4a16970e', options=None)
Thread-13739::INFO::2012-09-09 08:37:48,276::logUtils::39::dispatcher::(wrapper) Run and protect: getFloppyList, Return response: {'isolist': ['win2k3-32-with-virtio.vfd', 'win2k8-32_with_virtio.vfd', 'win7-32_with_virtio.vfd', 'virtio-drivers-1.0.0-45801.vfd', 'win2003-x64-unattended.vfd', 'win2k3.vfd', 'win2k8-R2.vfd', 'win2003-32-unattended.vfd', 'win2k3x64.vfd', 'virtio-win-1.4.0.vfd', 'win2000-Pro-unattended.vfd', 'win7-32.vfd', 'virtio-drivers.vfd', 'win7-64.vfd', 'virtio-drivers-1.0.0-8.vfd', 'virtio-win-1.1.16.vfd', 'win2k3-64-with-virtio.vfd', 'win7x64_with_virtio.vfd', 'win2k8-R2_with_virtio.vfd']}
Comment 4 Tomas Jelinek 2012-09-13 02:43:56 EDT
in u/s gerrit: http://gerrit.ovirt.org/#/c/7965/
Comment 7 Michal Skrivanek 2012-10-01 03:03:10 EDT
merged u/s as 84a07744ee63cbe0b698a0fc4fe3fe956f586f89
Comment 8 Itamar Heim 2012-10-06 16:17:07 EDT
*** Bug 863664 has been marked as a duplicate of this bug. ***
Comment 10 Michal Skrivanek 2012-10-26 05:05:05 EDT
*** Bug 870124 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.