Bug 855634 - [rhsc] create volume fails with no proper error on logs (The message key CreateGlusterVolume is missing from bundles/ExecutionMessages)
[rhsc] create volume fails with no proper error on logs (The message key Crea...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
unspecified
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Shireesh
Prasanth
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 09:21 EDT by Haim
Modified: 2014-01-12 19:54 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 09:07:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haim 2012-09-09 09:21:48 EDT
Description of problem:

1) create new volume from type distribute
2) create 3 bricks under this volume
3) add those bricks
4) hit create

error:

Error while executing action Create Gluster Volume: Volume create failed
error: Creation of volume hateya-si17-v1 has been unsuccessful
return code: 255

logs:


2012-09-09 16:09:09,634 WARN  [org.ovirt.engine.core.dal.job.ExecutionMessageDirector] (ajp--0.0.0.0-8009-3) [9ee4b2d] The message key CreateGlusterVolume is missing from bundles/ExecutionMessages
2012-09-09 16:09:11,947 INFO  [org.ovirt.engine.core.bll.gluster.CreateGlusterVolumeCommand] (ajp--0.0.0.0-8009-3) [9ee4b2d] Running command: CreateGlusterVolumeCommand internal: false. Entities affected :  ID: 99408929-82cf-4dc7-a532-9d998063fa95 Type: VdsGroups
2012-09-09 16:09:11,950 INFO  [org.ovirt.engine.core.vdsbroker.gluster.CreateGlusterVolumeVDSCommand] (ajp--0.0.0.0-8009-3) [9ee4b2d] START, CreateGlusterVolumeVDSCommand(vdsId = 2906ad06-f774-11e1-bb82-c3d9b0125c39), log id: 7ca0e21d
2012-09-09 16:09:12,098 INFO  [org.ovirt.engine.core.vdsbroker.gluster.CreateGlusterVolumeVDSCommand] (ajp--0.0.0.0-8009-3) [9ee4b2d] FINISH, CreateGlusterVolumeVDSCommand, log id: 7ca0e21d

expected results:

please provide meaningful information on engine logs which will allow me (or administrator) debug and understand why operation failed, if command was sent to vds (rhs-c), print that command, and print the error, which should include the underlying glusterfs or linux command that was used.
Comment 2 Shireesh 2012-09-25 10:42:14 EDT
The error you see in the log "Creation of volume hateya-si17-v1 has been unsuccessful" is exactly same as what the gluster CLI prints on executing the create volume command. So it's not a bug in RHS-C.

As far as the other warning "The message key CreateGlusterVolume is missing from bundles/ExecutionMessages" is concerned, this is already covered in bug 856102. Hence marking this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 856102 ***
Comment 3 Haim 2012-10-11 07:45:32 EDT
Shireesh, i'm not referring to the "The message key CreateGlusterVolume is missing from bundles/ExecutionMessages", please improve engine\vdsm logs, print the actual command executed by gluster, and enhance the error.
Comment 4 Shireesh 2012-10-11 07:52:33 EDT
What you see above is the exact error message returned by gluster cli. Unfortunately that is not good enough in the above case, but that's an issue with glusterfs and not engine/vdsm.

I don't think it is required to print the command executed in engine log - it is printed in the vdsm log.
Comment 5 Shireesh 2012-10-29 04:00:22 EDT
Hi Prasanth, I would like to close this bug. Let me know if you have any issues with this.
Comment 6 Prasanth 2012-11-14 07:25:03 EST
(In reply to comment #5)
> Hi Prasanth, I would like to close this bug. Let me know if you have any
> issues with this.

Shireesh, I don't have any issues with this. You may close this bug.

Note You need to log in before you can comment on or make changes to this bug.