Bug 855734 - [RFE] add configuration support for NFSv4 in TUI menus
[RFE] add configuration support for NFSv4 in TUI menus
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 02:52 EDT by Haim
Modified: 2016-04-26 10:21 EDT (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-6.el6
Doc Type: Enhancement
Doc Text:
Because of new support for advanced NFS options, users may choose the NFS server version for their configuration. The TUI menu on remote storage should now show the option to add an NFSv4 domain.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:38:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haim 2012-09-10 02:52:13 EDT
Description of problem:

both engine and vdsm are now support advanced NFS options which defines the way mount options are sent to vds (client), and also, user may chose NFS server version he works with, by default, its NFS v4, which requires additional configuration on client side (rhev-h), we need to add support to ease up the configuration process (since we don't expect users will edit /etc/idmapd.conf and persist the file afterwards).

desired configuration are:

/etc/idmapd.conf  --> should include the following line:

Domain = redhat.com (for example)

/etc/init.d/rpcidmapd restart 

nfsidmap -c
Comment 9 errata-xmlrpc 2013-02-28 11:38:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.