Bug 855774 - AVCs when running ncftool test with disabled unconfined and unlabelednet
AVCs when running ncftool test with disabled unconfined and unlabelednet
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.4
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Eduard Benes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 05:19 EDT by Michal Trunecka
Modified: 2014-10-14 03:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:56:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Trunecka 2012-09-10 05:19:23 EDT
Description of problem:
AVCs listed below were reported during automated test of ncftool with disabled unconfined and unlabelednet selinux modules. Test pass without any AVCs with both modules enabled.

----
time->Mon Sep 10 11:10:17 2012
type=PATH msg=audit(1347268217.508:2353): item=0 name="/var/run/radvd/radvd.pid"
type=CWD msg=audit(1347268217.508:2353):  cwd="/etc/sysconfig/network-scripts"
type=SYSCALL msg=audit(1347268217.508:2353): arch=c000003e syscall=4 success=no exit=-2 a0=17f1920 a1=7fff57e95de0 a2=7fff57e95de0 a3=8 items=1 ppid=32512 pid=8024 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ifup-eth" exe="/bin/bash" subj=system_u:system_r:udev_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1347268217.508:2353): avc:  denied  { search } for  pid=8024 comm="ifup-eth" name="radvd" dev=sda3 ino=155541 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:radvd_var_run_t:s0 tclass=dir


Version-Release number of selected component (if applicable):
netcf-0.1.9-2.el6.x86_64
selinux-policy-3.7.19-155.el6_3.noarch
selinux-policy-targeted-3.7.19-155.el6_3.noarch
selinux-policy-mls-3.7.19-155.el6_3.noarch


How reproducible:
always

Steps to Reproduce:
1. semodule -d unconfined; semodule -d unlabelednet
2. Run the automated test
/CoreOS/selinux-policy/Regression/bz593708-ncftool-cannot-read-files

  
Actual results:
AVC is reported during the test.

Expected results:
No AVC
Comment 7 errata-xmlrpc 2014-10-14 03:56:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1568.html

Note You need to log in before you can comment on or make changes to this bug.