Bug 855866 - aeolus-configure fails - postgresql-setup not available in RHEL
aeolus-configure fails - postgresql-setup not available in RHEL
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Mo Morsi
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 09:15 EDT by James Laska
Modified: 2013-09-02 03:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: aeolus-configure-2.8.6-1.el6cf
Doc Type: Bug Fix
Doc Text:
PostgreSQL in Red Hat Enterprise Linux did not contain a postgresql-setup script. This caused aeolus-configure to fail when configuring PostgreSQL. This fix modifies aeolus-configure to run initdb instead. aeolus-configure now sets up PostgreSQL successfully.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:18:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 14:51:45 EST

  None (edit)
Description James Laska 2012-09-10 09:15:20 EDT
Description of problem:

Aeolus-configure fails while attempting to setup postgresql (full beaker logs available at https://beaker.engineering.redhat.com/jobs/294123).

It appears, the command used (postgresql-setup) is *not* available in the version of postgresql-server included in RHEL.

The code was introduced as part of upstream patch ...
> git show 463412310315a8b58002d8c8c16b091920b7d0d6

RHEL does not include a version of postgresql-server that includes the command 'postgresql-setup'.  That command appears *only* availble in the >= 0.9.1 version of postgresql-server (included in Fedora)

Version-Release number of selected component (if applicable):
 * aeolus-configure-2.8.3-1.el6cf.noarch

How reproducible:
 * Pretty easy

Steps to Reproduce:
1. Install aeolus-all
2. Run aeolus-configure
  
Actual results:

> Launching aeolus configuration recipe...
> notice: /File[/data]/ensure: created[0m
> notice: /File[/data/db]/ensure: created[0m
> notice: /Stage[main]/Aeolus::Iwhd/Service[mongod]/ensure: ensure changed 'stopped' to 'running'[0m
> notice: /File[/etc/init.d/iwhd]/content: content changed '{md5}b1ffdf2a6e7b57f65537bf40ba3102c9' to '{md5}6e6aa5a83a15929d7d3ef426475a5f1e'[0m
> notice: /File[/etc/init.d/iwhd]/seltype: seltype changed 'iwhd_initrc_exec_t' to 'initrc_exec_t'[0m
> notice: /File[/etc/iwhd/users.js]/content: content changed '{md5}1d1cc4ee732cdfd775c2bac6096e18fc' to '{md5}aee3d3ec82f0b0cf4e3659a48653ed38'[0m
> notice: /File[/etc/imagefactory/imagefactory.conf]/mode: mode changed '644' to '600'[0m
> notice: /File[/etc/httpd/conf.d/aeolus-conductor.d]/ensure: created[0m
> notice: /File[/etc/rsyslog.d/aeolus.conf]/ensure: defined content as '{md5}2d45434a072b4f9d1518ce026b92c547'[0m
> notice: /Stage[main]/Aeolus::Image-factory/Service[libvirtd]/ensure: ensure changed 'stopped' to 'running'[0m
> notice: /Stage[main]/Aeolus::Image-factory/File[/var/tmp/imagefactory-mock]/ensure: created[0m
> notice: /File[/rsyslog]/ensure: created[0m
> notice: /File[/rsyslog/work]/ensure: created[0m
> notice: /Stage[main]/Aeolus::Conductor/Service[rsyslog]: Triggered 'refresh' from 1 events[0m
> notice: /File[/usr/share/aeolus-conductor/config/settings.yml]/content: content changed '{md5}e554310b717ab9218f4d136cdc7994f4' to '{md5}5f6c56ea63bc02a07bed5f4a454c22ea'[0m
> notice: /File[/usr/share/aeolus-conductor/config/initializers/secret_token.rb]/ensure: defined content as '{md5}691df0bc0e1be07dd8fca0953d847b8d'[0m
> notice: /File[/etc/ldap_fluff.yml]/content: content changed '{md5}b27213de9f26cf3a5e689c1ab7d2c2b6' to '{md5}109fb977032121710c47df851d8f0e72'[0m
> notice: /File[/etc/ldap_fluff.yml]/group: group changed 'root' to 'aeolus'[0m
> notice: /File[/etc/ldap_fluff.yml]/mode: mode changed '644' to '640'[0m
> notice: /Stage[main]/Aeolus::Deltacloud::Core/Service[deltacloud-core]/ensure: ensure changed 'stopped' to 'running'[0m
> notice: /Stage[main]/Aeolus::Deltacloud::Core/Exec[deltacloud-core-startup-wait]/returns: executed successfully[0m
> notice: /Stage[main]/Aeolus::Image-factory/Augeas[imagefactory.conf]/returns: executed successfully[0m
> notice: /Stage[main]/Aeolus::Image-factory/Service[imagefactory]/ensure: ensure changed 'stopped' to 'running'[0m
> notice: /Stage[main]/Apache/Service[httpd]/ensure: ensure changed 'stopped' to 'running'[0m
> notice: /File[/etc/httpd/conf.d/aeolus-conductor.conf]/content: content changed '{md5}8129c1ef2030ef66c0437b5d49115c3d' to '{md5}411f7850e4e060690c690c011630b9a7'[0m
> notice: /Stage[main]/Apache/Exec[reload-apache]: Triggered 'refresh' from 2 events[0m
> err: /Stage[main]/Postgres::Server/Exec[pginitdb]/returns: change from notrun to 0 failed: Could not find command 'postgresql-setup'[0m
> notice: /Stage[main]/Aeolus::Conductor/Exec[pgauthuser]: Dependency Exec[pginitdb] has failures: true[0m
> warning: /Stage[main]/Aeolus::Conductor/Exec[pgauthuser]: Skipping because of failed dependencies[0m
> notice: /Stage[main]/Postgres::Server/Service[postgresql]: Dependency Exec[pginitdb] has failures: true[0m
> warning: /Stage[main]/Postgres::Server/Service[postgresql]: Skipping because of failed dependencies[0m

Expected results:

> aeolus-configure should not fail

Additional info:
Comment 3 Giulio Fidente 2012-09-18 15:39:01 EDT
works for me with aeolus-configure-2.8.6-1.el6cf
Comment 5 errata-xmlrpc 2012-12-04 10:18:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.