Bug 85600 - After sync our Satellite Server doesn't show affected systems
After sync our Satellite Server doesn't show affected systems
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike Orazi
Red Hat Satellite QA List
https://rhn.mediaways.net
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-04 16:34 EST by Christian Stelter
Modified: 2008-11-20 12:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 12:23:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Satellite Server Logfile (28.68 KB, application/octet-stream)
2003-04-01 11:27 EST, Christian Stelter
no flags Details
actual logfile (70.37 KB, application/octet-stream)
2003-04-03 10:09 EST, Christian Stelter
no flags Details

  None (edit)
Description Christian Stelter 2003-03-04 16:34:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
Hi!

After doing an sync we're unable to get a list of "affected systems" for a
specific package (last sendmail update) via web admin frontend.

The affected systems count is zero although probably all systems with sendmail
need to get an update. When checked with up2date -l on an affected system the
sendmail update is listed.

That's rather unpractical for tracking open security issues. :-/

The package versions:

rhns-server-1.2.6.1-5
rhn-satellite-admin-1.0-10
rhn-satellite-config-1.1-34
rhns-1.2.6.1-5
rhns-app-1.2.6.1-5
rhns-satellite-tools-1.2.6.1-5
rhns-schema-tools-1.3.0-2

Any help appreciated.

Best regards, Christian


Version-Release number of selected component (if applicable): 1.2.6.1-5


How reproducible:
Always

Steps to Reproduce:
1. Login into Satellite Server as Admin
2. go to Errata/All Errata
3. see the first line of the packages list


Actual Results:  1. "RHSA-2003:073-06  Security Advisory  Updated sendmail
packages fix critical security issues  0  2003-03-02"
2. sadness


Expected Results:  1. an affected system count > 0
2. a list of affected system in order to keep track of the update process

Additional info:
Comment 1 Bret McMillan 2003-03-04 17:11:23 EST
1.  The system on which up2date -l shows send mail is pointing at the satellite
server, correct?
2.  What version of rhnproc are you running?  

rpm -q rhnproc

Also, can you see the errata at the following url:

https://your.satellite.server.com/network/errata/errata_details.pxt?adv=RHSA-2003:073

If you can see the information about the errata, the information is being synced
correctly.  Most likely, a needed background process is not being run.
Comment 2 Christian Stelter 2003-03-05 03:17:09 EST
rhnproc-0.7-1

And Yes I can see the information about the errata.

So what background process has to be checked?
Comment 3 Christian Stelter 2003-03-05 03:18:11 EST
Oh. And yes the system I used for the test for up2date was pointing to our
satellite server.
Comment 4 Christian Stelter 2003-03-05 03:20:18 EST
[root@lnxc-115 root]# rpm -ql rhnproc
/etc/rc.d/init.d/rhnproc
/usr/sbin/rhnproc.pl
[root@lnxc-115 root]# ps -ef|grep rhnproc
root     25106     1  0  2002 ?        00:00:49 rhnproc.pl
daemon    2331 25106  0  2002 ?        00:00:00 [rhnproc.pl <defunct>]

Hmm. The defunct process does not look ok. I will restart the process and try
another sync.
 
Comment 5 Christian Stelter 2003-03-05 05:51:01 EST
Restarting rhnproc.pl helped... after another resync of channels I now get a
correct system count.
Comment 6 Bret McMillan 2003-03-05 13:42:39 EST
Anything in your logs about why the process went defunct?
Comment 7 Christian Stelter 2003-03-12 10:21:30 EST
Sorry. Didn't manage to look earlier in the logs. Now they've been rotated. :-(
Comment 8 Bret McMillan 2003-03-12 10:39:41 EST
That's ok.  For now I'm going to close this bug, but please keep an eye on the
rhnproc process... if you see continued problems with it, please either reopen
this bug or file a new one, and we'll see what's affecting it.
Comment 9 Christian Stelter 2003-04-01 11:26:53 EST
We have the same effect again. After today's sync of our channels we're unable
to see the latest sendmail-Errata's although they have been synced.

Channel 7.2
Tue Apr  1 10:04:14 2003 -    149/152 Fetch successful:
sendmail-8.11.6-25.72.i386.rpm (304190 bytes)

See also satellite log attached.
Comment 10 Christian Stelter 2003-04-01 11:27:59 EST
Created attachment 90812 [details]
Satellite Server Logfile

See problem description above.
Comment 11 Christian Stelter 2003-04-01 11:29:28 EST
This time there is no defunct rhnproc.pl (see comment #5).
Comment 12 Bret McMillan 2003-04-01 11:53:37 EST
Christian, can you tell me the name of the Red Hat technical contact that helped
install this Satellite?  There appears to be a missing table in the db that is
causing the errata import process to fail.

It would also help if you can provide your Satellite DBA's contact information
as well.
Comment 13 Christian Stelter 2003-04-02 02:26:44 EST
Greg DeKoenigsberg was the Red Hat technical contact as far as I know. None of
our DBA's are involved with the DB on that Satellite Server. 

The last person who got in contact with the DB on our side was me. I modified
the tables as instructed by your collegues while applying the last update.
 
Comment 14 Christian Stelter 2003-04-03 07:05:44 EST
We're currently unable to update our sendmails. 
 
That's a big problem.
Comment 15 Christian Stelter 2003-04-03 08:58:07 EST
Problem solved with the following actions:

apache stopped
rhnproc stopped
apache started
rhnproc started
satellite-sync run

After this we could see the updates again.

A fix that avoids this problem would be nice.
Comment 16 Bret McMillan 2003-04-03 09:49:53 EST
Christian, if you could send the log of that last sync that worked, I'd
appreciate it.  It seemed as if you are missing a table in the db that should
have caused you problems.  I want to verify that everything is working properly.
Comment 17 Christian Stelter 2003-04-03 10:09:55 EST
Created attachment 90867 [details]
actual logfile 

Logfile from today as requested.
Comment 18 Josef Komenda 2003-04-03 10:15:15 EST
I'm seeing the same error on a newly installed satellite - errata import fails.
These are the errors in the rhn_server_satellite.log:

2003/04/03 10:07:22 18781 0.0.0.0:
satellite_tools/xmlSource.endItemCallback('XML parser error: found "rhn-error"
item: Error: \012RHN::Exception: DBD::Oracle::db prepare failed: ORA-00942:
table or view does not exist (DBD ERROR: OCIStmtExecute/Describe)\012  main
/var/www/cgi-bin/satellite.pl 128 RHN::DB::handle_error\012  Frontier::RPC2
/usr/lib/perl5/site_perl/5.6.1/Frontier/RPC2.pm 136 main::errata_dump\012 
Frontier::RPC2 /usr/lib/perl5/site_perl/5.6.1/Frontier/RPC2.pm 136 (eval)\012 
main /var/www/cgi-bin/satellite.pl 51 Frontier::RPC2::serve\012  main
/var/www/cgi-bin/satellite.pl 50 (eval)\012\012Offending Query: SELECT
errata_id, md5sum, filename FROM rhnErrataChecksum WHERE errata_id IN (?)\012\012',)


Thu Apr  3 10:07:22 2003 -        ('rhn-erratum-1538',): ERROR: parser exception
occured: Error:                                                               
RHN::Exception: DBD::Oracle::db prepare failed: ORA-00942: table or view does
not exist (DBD ERROR: OCIStmtExecute/Describe)                                 
    main /var/www/cgi-bin/satellite.pl 128 RHN::DB::handle_error               
    Frontier::RPC2 /usr/lib/perl5/site_perl/5.6.1/Frontier/RPC2.pm 136
main::errata_dump                                                              
             Frontier::RPC2 /usr/lib/perl5/site_perl/5.6.1/Frontier/RPC2.pm 136
(eval)       main /var/www/cgi-bin/satellite.pl 51 Frontier::RPC2::serve       
             main /var/www/cgi-bin/satellite.pl 50 (eval)                      
                                                                               
           Offending Query: SELECT errata_id, md5sum, filename FROM
rhnErrataChecksum WHERE errata_id IN (?)                                       
                                                                               
                       , id: ['rhn-erratum-1538']
Comment 19 Josef Komenda 2003-04-03 11:51:35 EST
A revised satellite.pl was pushed that fixed this problem - run:
satellite-sync
Comment 20 Clifford Perry 2008-11-20 12:23:35 EST
This seems to be an old legacy bug. I am closing this bugzilla out. If you are still encountering issues with this issue on your Satellite, please file a support ticket for continued assistance. 

Regards,
Clifford.

Note You need to log in before you can comment on or make changes to this bug.