Bug 856004 - Error page displayed when accessing locale page
Error page displayed when accessing locale page
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.7
Unspecified Unspecified
high Severity urgent
: ---
: 1.7
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 18:24 EDT by Alex Eng
Modified: 2012-11-29 18:29 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.7.3-SNAPSHOT (20120911-0844)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 18:29:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Eng 2012-09-10 18:24:28 EDT
Description of problem:
When try with URL https://{zanata.host}/zanata/language/view/{locale}
Error message displayed.

Unexpected error. Please try again

Version-Release number of selected component (if applicable):
1.7.1
Comment 2 Ding-Yi Chen 2012-09-10 21:43:03 EDT
VERIFIED with Zanata version 1.7.3-SNAPSHOT (20120911-0844)
Comment 3 Sean Flanigan 2012-09-11 01:05:25 EDT
Just for reference, I was able to reproduce it by directly visiting https://translate.zanata.org/zanata/language/view/{locale} in a fresh web browser (or incognito session).  It doesn't happen if you visit the Languages page first.

This is the exception logged by the server:

javax.el.ELException: Error writing 'language' on type org.zanata.action.LanguageTeamAction_$$_javassist_seam_68 
    	at javax.el.BeanELResolver.setValue(BeanELResolver.java:133) 
    	at javax.el.CompositeELResolver.setValue(CompositeELResolver.java:69) 
    	at com.sun.faces.el.FacesCompositeELResolver.setValue(FacesCompositeELResolver.java:100) 
    	at org.jboss.el.parser.AstPropertySuffix.setValue(AstPropertySuffix.java:73) 
    	at org.jboss.el.parser.AstValue.setValue(AstValue.java:84) 
    	at org.jboss.el.ValueExpressionImpl.setValue(ValueExpressionImpl.java:249) 
    	at org.jboss.seam.core.Expressions$1.setValue(Expressions.java:117) 
    	at org.jboss.seam.navigation.Pages.applyConvertedValidatedValuesToModel(Pages.java:846) 
    	at org.jboss.seam.navigation.Pages.postRestore(Pages.java:443) 
    	at org.jboss.seam.jsf.SeamPhaseListener.postRestorePage(SeamPhaseListener.java:545) 
    	at org.jboss.seam.jsf.SeamPhaseListener.afterRestoreView(SeamPhaseListener.java:394) 
    	at org.jboss.seam.jsf.SeamPhaseListener.afterServletPhase(SeamPhaseListener.java:230) 
    	at org.jboss.seam.jsf.SeamPhaseListener.afterPhase(SeamPhaseListener.java:196) 
    	at com.sun.faces.lifecycle.Phase.handleAfterPhase(Phase.java:175) 
    	at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:114) 
    	at com.sun.faces.lifecycle.RestoreViewPhase.doPhase(RestoreViewPhase.java:102) 
    	at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118) 
    	at javax.faces.webapp.FacesServlet.service(FacesServlet.java:265) 
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290) 
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) 
    	at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:638) 
    	at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:444) 
    	at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:382) 
    	at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:310) 
    	at org.tuckey.web.filters.urlrewrite.NormalRewrittenUrl.doRewrite(NormalRewrittenUrl.java:195) 
    	at org.tuckey.web.filters.urlrewrite.RuleChain.handleRewrite(RuleChain.java:159) 
    	at org.tuckey.web.filters.urlrewrite.RuleChain.doRules(RuleChain.java:141) 
    	at org.tuckey.web.filters.urlrewrite.UrlRewriter.processRequest(UrlRewriter.java:90) 
    	at org.tuckey.web.filters.urlrewrite.UrlRewriteFilter.doFilter(UrlRewriteFilter.java:406) 
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) 
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) 
    	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:83) 
    	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:73) 
    	at org.jboss.seam.web.ExceptionFilter.doFilter(ExceptionFilter.java:64) 
    	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69) 
    	at org.ajax4jsf.webapp.BaseXMLFilter.doXmlFilter(BaseXMLFilter.java:206) 
    	at org.ajax4jsf.webapp.BaseFilter.handleRequest(BaseFilter.java:290) 
    	at org.ajax4jsf.webapp.BaseFilter.processUploadsAndHandleRequest(BaseFilter.java:388) 
    	at org.ajax4jsf.webapp.BaseFilter.doFilter(BaseFilter.java:515) 
    	at org.jboss.seam.web.Ajax4jsfFilter.doFilter(Ajax4jsfFilter.java:56) 
    	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69) 
    	at org.jboss.seam.web.LoggingFilter.doFilter(LoggingFilter.java:60) 
    	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69) 
    	at org.jboss.seam.servlet.SeamFilter.doFilter(SeamFilter.java:158) 
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) 
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) 
    	at org.zanata.seam.interceptor.MonitoringWrapper.doFilter(MonitoringWrapper.java:70) 
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) 
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) 
    	at org.zanata.servlet.GWTCacheControlFilter.doFilter(GWTCacheControlFilter.java:63) 
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) 
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) 
    	at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96) 
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) 
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) 
    	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235) 
    	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) 
    	at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:183) 
    	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:442) 
    	at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:95) 
    	at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126) 
    	at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70) 
    	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) 
    	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) 
    	at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158) 
    	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) 
    	at org.jboss.web.tomcat.service.request.ActiveRequestResponseCacheValve.internalProcess(ActiveRequestResponseCacheValve.java:74) 
    	at org.jboss.web.tomcat.service.request.ActiveRequestResponseCacheValve.invoke(ActiveRequestResponseCacheValve.java:47) 
    	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330) 
    	at org.apache.coyote.ajp.AjpProcessor.process(AjpProcessor.java:436) 
    	at org.apache.coyote.ajp.AjpProtocol$AjpConnectionHandler.process(AjpProtocol.java:385) 
    	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:451) 
    	at java.lang.Thread.run(Thread.java:679) 
    Caused by: org.jboss.seam.RequiredException: @In attribute requires non-null value: languageTeamAction.memberLanguage 
    	at org.jboss.seam.Component.getValueToInject(Component.java:2335) 
    	at org.jboss.seam.Component.injectAttributes(Component.java:1736) 
    	at org.jboss.seam.Component.inject(Component.java:1554) 
    	at org.jboss.seam.core.BijectionInterceptor.aroundInvoke(BijectionInterceptor.java:61) 
    	at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:68) 
    	at org.jboss.seam.transaction.TransactionInterceptor$1.work(TransactionInterceptor.java:97) 
    	at org.jboss.seam.util.Work.workInTransaction(Work.java:47) 
    	at org.jboss.seam.transaction.TransactionInterceptor.aroundInvoke(TransactionInterceptor.java:91) 
    	at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:68) 
    	at org.jboss.seam.core.MethodContextInterceptor.aroundInvoke(MethodContextInterceptor.java:44) 
    	at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:68) 
    	at org.jboss.seam.security.SecurityInterceptor.aroundInvoke(SecurityInterceptor.java:163) 
    	at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:68) 
    	at org.jboss.seam.core.SynchronizationInterceptor.aroundInvoke(SynchronizationInterceptor.java:32) 
    	at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:68) 
    	at org.jboss.seam.intercept.RootInterceptor.invoke(RootInterceptor.java:107) 
    	at org.jboss.seam.intercept.JavaBeanInterceptor.interceptInvocation(JavaBeanInterceptor.java:185) 
    	at org.jboss.seam.intercept.JavaBeanInterceptor.invoke(JavaBeanInterceptor.java:103) 
    	at org.zanata.action.LanguageTeamAction_$$_javassist_seam_68.setLanguage(LanguageTeamAction_$$_javassist_seam_68.java) 
    	at sun.reflect.GeneratedMethodAccessor2852.invoke(Unknown Source) 
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) 
    	at java.lang.reflect.Method.invoke(Method.java:616) 
    	at javax.el.BeanELResolver.setValue(BeanELResolver.java:129) 
    	... 72 more

Note You need to log in before you can comment on or make changes to this bug.