Bug 856006 - nss-pam-ldapd not upgradable due to a conflict with pam_ldap
nss-pam-ldapd not upgradable due to a conflict with pam_ldap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nss-pam-ldapd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 19:06 EDT by Michal Jaegermann
Modified: 2013-01-18 15:43 EST (History)
2 users (show)

See Also:
Fixed In Version: nss-pam-ldapd-0.8.12-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 15:43:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2012-09-10 19:06:57 EDT
Description of problem:

And attempt to update the current rawhide ends up with:

Transaction Check Error:
  file /lib64/security/pam_ldap.so from install of
nss-pam-ldapd-0.7.17-1.fc19.x86_64 conflicts with file from package
pam_ldap-185-14.fc18.x86_64

What is more nss-pam-ldapd-0.7.16-4.fc18 depends on pam_ldap so an attempt to remove the later ends up removing the former as well.

It appears that nss-pam-ldapd-0.7.17-1.fc19 can indeed to without
pam_ldap-185-14.fc18 but missing "obsoletes" and/or "provides" result in the error as above.  One can workaround this with 'yum shell' by removing pam_ldap
and updating nss-pma-ldapd in a single transaction but 'yum update' breaks.

Version-Release number of selected component (if applicable):
nss-pam-ldapd-0.7.17-1.fc19
Comment 1 Nalin Dahyabhai 2013-01-18 15:43:29 EST
Updating the provides/obsoletes to cover the version of pam_ldap in F18, which should fix this.

Note You need to log in before you can comment on or make changes to this bug.