This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 856253 - Double click on "connect" in Add Existing Cluster dialog leads to listing the nodes twice
Double click on "connect" in Add Existing Cluster dialog leads to listing the...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 10:56 EDT by Jan Pokorný
Modified: 2013-02-21 03:22 EST (History)
3 users (show)

See Also:
Fixed In Version: luci-0.26.0-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:22:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2012-09-11 10:56:30 EDT
1. fire up Add Existing Cluster dialog
2. fill in details for one node
3. click Connect twice in a short period of time (before the response
   for the first AJAX request comes back)

BAD:

Respective nodes listed twice.

GOOD:

Respective nodes listed just once, no matter how many clicks there were.
Comment 1 Jan Pokorný 2012-09-11 10:59:07 EDT
Note: there may be more situations like this.
Comment 2 Ryan McCabe 2012-09-28 11:12:25 EDT
Should be easy enough to fix by disabling the submit button while we're waiting for the response.
Comment 3 Ryan McCabe 2012-10-08 09:58:09 EDT
commit 72fa237fc759c83c927d87bad5ee8d51dab3c0db
Author: Ryan McCabe <rmccabe@redhat.com>
Date:   Mon Oct 8 09:55:18 2012 -0400

    luci: Fix double click on add existing dialog
    
    Fix a bug that caused nodes to be listed twice if you accidentally
    double clicked the "Connect" button on the add existing cluster
    dialog.
    
    Resolves: rhbz#856253
    
    Signed-off-by: Ryan McCabe <rmccabe@redhat.com>
Comment 7 errata-xmlrpc 2013-02-21 03:22:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0309.html

Note You need to log in before you can comment on or make changes to this bug.