Bug 856425 - brctl: cannot change forward delay to non-default value while STP=ON
brctl: cannot change forward delay to non-default value while STP=ON
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Herbert Xu
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 23:12 EDT by Charles Butterfield
Modified: 2014-01-28 03:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-28 03:48:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Butterfield 2012-09-11 23:12:56 EDT
Description of problem: Although one can use "brctl setfd <bridge> <secs>" to change the forward delay while STP=OFF, the value reverts to the 15-second default when STP is enabled, and is unchangeable while STP is enabled.


Version-Release number of selected component (if applicable): 2.6.32-279.5.2.el6.x86_64


How reproducible: 100%


Steps to Reproduce:
1. brctl stp br0 off
2. brctl setfd br0 5 # yup it changes per showstp
3. brctl stp br0 on  # forward delay reverts to 15
4. brctl setfd br0 5 # no effect
  
Actual results: delay reverts to 15 when STP enabled and also cannot be changed.


Expected results:
1) No change in delay when enabling STP
2) Ability to change delay while STP is enabled.


Additional info:
Comment 2 Herbert Xu 2012-09-24 04:45:59 EDT
Can you clarify what you mean by step 4 having no effect? In particular, if you look at the bridge stats is forward delay not set to zero? Or do you mean that even though the forward delay parameter is set to zero, the bridge is still delaying the forwarding on that port?

Thanks.
Comment 3 Charles Butterfield 2012-09-25 19:05:16 EDT
By step (4) I mean that b"brctl showstp br0" still shows the value of 15, not 5.  I did assume that the display is correct.
Comment 4 Herbert Xu 2014-01-28 03:48:13 EST
Setting when STP is on has no effect because the kernel will ensure that the value is in a legal range.  The range check is only performed when STP is enabled.   That's why there is no effect.

Note You need to log in before you can comment on or make changes to this bug.