Bug 856434 - Failed to boot rhel5 guest with virtio block that is previously installed with ide block
Failed to boot rhel5 guest with virtio block that is previously installed wit...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 23:46 EDT by Qunfang Zhang
Modified: 2013-12-19 13:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 13:24:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic screenshot (22.77 KB, image/png)
2012-09-11 23:47 EDT, Qunfang Zhang
no flags Details

  None (edit)
Description Qunfang Zhang 2012-09-11 23:46:36 EDT
Description of problem:
Failed to boot rhel5 guest with virtio block that is previously installed with ide block, because can not find virtio_blk module. Guest will kernel panic. 
rhel6 guest works well with this scenario. Hope can fix this to boot a rhel5 guest and switch disk interface. 

Version-Release number of selected component (if applicable):
RHEL5.8 released guest version

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Qunfang Zhang 2012-09-11 23:47:20 EDT
Created attachment 611975 [details]
kernel panic screenshot
Comment 2 RHEL Product and Program Management 2013-05-01 03:12:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Brian Lane 2013-12-19 13:24:21 EST
When switching drivers you need to rebuild the initrd with the new drivers before rebooting. You can do this by passing --with=virtio_blk to mkinitrd (you will probably also need virtio_pci and possibly others).

eg.

mkinitrd --with=virtio_blk --with=virtio_pci -f initrd-`uname -r`.img `uname -r`

Note You need to log in before you can comment on or make changes to this bug.