Bug 856478 - After subscribing the quantity of subscription is set to 0
After subscribing the quantity of subscription is set to 0
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-12 02:17 EDT by Shwetha Kallesh
Modified: 2013-01-10 06:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 13:37:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quantity is set to zero (106.54 KB, image/png)
2012-09-12 02:17 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Shwetha Kallesh 2012-09-12 02:17:16 EDT
Created attachment 611995 [details]
Quantity is set to zero

Description of problem:
After subscribing the quantity of subscription is set to 0

Version-Release number of selected component (if applicable):
[root@dhcp201-146 pki]# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.17-1.el5
subscription-manager-1.0.17-1.el5
subscription-manager-gui-1.0.17-1.el5
subscription-manager-firstboot-1.0.17-1.el5
subscription-manager-migration-data-1.11.2.4-1.el5


How reproducible:


Steps to Reproduce:
1.Subscription-manager-gui
2.All available tab,subscribe a multi-entitled product
I subscribed Awesome OS With Upto 4 virtual guests

3.
  
Actual results:
quantity sets to zero
PS:attachment for details

Expected results:


Additional info:
Comment 1 Michael Stead 2012-09-14 08:00:13 EDT
IIRC, this is intended behavior. The intent was to show that the system has satisfied quantity for this product. Subscription Manager will do its best to provide a default quantity. 0 is the default meaning that none are required.
Comment 2 John Sefler 2012-09-14 08:32:06 EDT
(In reply to comment #1)
> IIRC, this is intended behavior. The intent was to show that the system has
> satisfied quantity for this product. Subscription Manager will do its best
> to provide a default quantity. 0 is the default meaning that none are
> required.
Agreed.

I'm confident that what made this suspicious is that the filter setting for "have no overlap with existing subscriptions" was unchecked which would cause this multi-entitlement subscription to continue to display in the available subscriptions tab with a default quantity of 0 since that (as mstead said) is the necessary amount needed to achieve compliance for the products that subscription covers.

In my opinion, this is not a bug and is properly working as designed.
Comment 3 James Bowes 2012-09-24 13:37:44 EDT
Closing this out, since it's working as designed.

Note You need to log in before you can comment on or make changes to this bug.