Bug 856500 - Administration and Configuration Guide Chapter 13.2.3 Note section's description are inaccurate.
Administration and Configuration Guide Chapter 13.2.3 Note section's descript...
Status: CLOSED DUPLICATE of bug 887219
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.1
All All
unspecified Severity high
: ---
: EAP 6.1.0
Assigned To: Russell Dickenson
kylin
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 03:21 EDT by kylin
Modified: 2013-03-15 00:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.4 Build Filter: null Build Name: Build Date: 12-06-2012 19:15:42
Last Closed: 2013-03-15 00:27:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kylin 2012-09-12 03:21:47 EDT
Description of problem:
Administration and Configuration Guide Chapter 13.2.3 Note section:
" If you use a standalone server, modify Management CLI commands by removing the /profile=default from the beginning of any Management CLI commands.
"
But when I try this command:
---
/subsystem=web/connector=HTTPS/ssl=configuration/:writeattribute(name=password,value=password)
---
The following Exception threw:
---
Failed to get the list of the operation properties: "JBAS014753: There is no operation writeattribute registered at address [
    ("subsystem" => "web"),
    ("connector" => "HTTPS"),
    ("ssl" => "configuration")
]"
---

Also, when I try this:
---
/subsystem=web/connector=HTTPS/ssl=configuration/:write-attribute(name=name,value=https)
---
The following Error threw:
---
{
    "outcome" => "failed",
    "failure-description" => "JBAS014807: Management resource '[
    (\"subsystem\" => \"web\"),
    (\"connector\" => \"HTTPS\"),
    (\"ssl\" => \"configuration\")
]' not found",
    "rolled-back" => true
}
---


Version-Release number of selected component (if applicable):
JBoss EAP 6.0.0

How reproducible:
Do SSL configuration as Documents 13.2.3 say.

  
Actual results:
CLI execute failed and roll back


Expected results:
CLI can execute successful.

Additional info:
Comment 1 Misty Stanley-Jones 2012-09-12 20:45:35 EDT
The problem here is that the  connector name is case-sensitive. Use the following command and it should work properly:

/subsystem=web/connector=https/:write-attribute(name=secure,value=true)

Note that this topic has had signficant updates since the 6.0.0 GA and is now significantly different on internal documentation stage. Please check there and let me know if more updates are needed.
Comment 3 Jakub Cechacek 2013-03-07 08:40:33 EST
Link from above is not working anymore. Changing status to assigned -- please provided information about current status of this issue.
Comment 4 Russell Dickenson 2013-03-13 22:31:24 EDT
The corrected link to the section 13.2.3 is at [1]. Note that at [1] there is a typo in the first paragraph - "SSL-encryoted" should be "SSL-encrypted". This has already been corrected.

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6/html-single/Administration_and_Configuration_Guide/index.html#Implement_SSL_Encryption_for_the_JBoss_Enterprise_Application_Platform_Web_Server1
Comment 5 Jakub Cechacek 2013-03-14 05:16:24 EDT
First of all AFAIK the most reset docs are [1]

in example 13.4
/profile=default/subsystem=web/connector=https/ssl=configuration:add(name=https,certificate-key-file=${jboss.server.config.dir}/keystore.jks,password=SECRET, key-alias=KEY_ALIAS)

the connector is being referred to as "https" even though it was named "HTTPS" in previous example -- name it consistently "HTTPS" 

Also because of this I believe that this issue is in fact a duplicate of BZ887219. However I'm not entirely sure about it. Close this issue if I'm right, thanks. 


[1] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6-Beta/html-single/Administration_and_Configuration_Guide/index.html#Implement_SSL_Encryption_for_the_JBoss_Enterprise_Application_Platform_Web_Server1
Comment 6 Russell Dickenson 2013-03-15 00:27:50 EDT
Jakub,

(1) You're correct in that I provided the wrong link. Sorry for that.
(2) You're also correct that this is a duplicate of BZ#887219. I checked that BZ ticket and the corrections have been made in that ticket so I have closed this as a duplicate.

*** This bug has been marked as a duplicate of bug 887219 ***

Note You need to log in before you can comment on or make changes to this bug.