Bug 856539 - Error messages come in geo-rep gluster logs whenever there is a setxattr call.
Error messages come in geo-rep gluster logs whenever there is a setxattr call.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
Vijaykumar Koppad
:
Depends On:
Blocks: 856541
  Show dependency treegraph
 
Reported: 2012-09-12 05:23 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa4-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 856541 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:38:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2012-09-12 05:23:24 EDT
Description of problem: The error messages are logged in geo-rep gluster logs whenever   there is a setxattr call. 

[2012-09-11 20:11:24.591271] E [mem-pool.c:503:mem_put] (-->/usr/lib64/glusterfs/3.3.0rhs/xlator/cluster/replicate.so(afr_setxattr_wind_cbk+0xe6) [0x7f17044c7426](/usr/lib64/glusterfs/3.3.0rhs/xlator/cluster/replicate.so(afr_setxattr_unwind+0xe3) [0x7f17044c4f13] (-->/usr/lib64/glusterfs/3.3.0rhs/xlator/cluster/distribute.so(dht_err_cbk+0xfd) [0x7f170427c67d]))) 0-mem-pool: invalid argument



Version-Release number of selected component (if applicable):RHS-2.0.z 


How reproducible:Consistently 


Steps to Reproduce:
1.Create large set of data on the master 
2.Start a geo-rep session between master(dist-rep)  and slave(dist-repl)
3. Look for the error messages in geo-rep gluster logs. 

  
Actual results: The error messages occur 


Expected results:There shouldn't be any error message. 


Additional info:
Comment 2 Vijaykumar Koppad 2013-01-10 03:35:30 EST
Verified in glusterfs-3.4.0qa5-1.el6rhs
Comment 3 Scott Haines 2013-09-23 18:38:37 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 4 Scott Haines 2013-09-23 18:41:27 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.