Bug 856573 - The servicelevel option in rhn-migrate-classic-to-rhsm --help  is incorrect
The servicelevel option in rhn-migrate-classic-to-rhsm --help  is incorrect
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.4
Assigned To: Alex Wood
Entitlement Bugs
: QA-Closed
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-09-12 06:47 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:56:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-09-12 06:47:21 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
4/4

Prerequisites : 
Rhel5.9 with following error message.
subscription-manager-gui-1.0.17-1.el5
subscription-manager-1.0.17-1.el5
subscription-manager-firstboot-1.0.17-1.el5
subscription-manager-migration-data-1.11.2.4-1.el5
subscription-manager-migration-1.0.17-1.el5


steps to repro : 
Login to client console and execute following command 

rhn-migrate-classic-to-rhsm –help

Expected Result : 
entry should be  For no service level use --servicelevel="" 

Actual Result : 

 -s SERVICELEVEL, --servicelevel=SERVICELEVEL
                        Service level to subscribe this system to. For no
                        service level use --service-level=""
Comment 1 Bryan Kearney 2012-09-19 11:16:36 EDT
agree, but it is after string freeze. Moving this to rhel 6
Comment 3 Adrian Likins 2012-11-19 10:25:21 EST
commit e4f48fc92dd2bd340cf6984040217f708f2790ac
Author: Alex Wood <awood@redhat.com>
Date:   Thu Nov 8 18:38:07 2012 -0500

    856573: Correct typo in migration script help text.
Comment 6 spandey 2012-11-26 04:01:01 EST
Verified using following rpm 

subscription-manager-1.8.0-1.git.3.006a990.el6.x86_64
subscription-manager-migration-1.8.0-1.git.3.006a990.el6.x86_64
subscription-manager-firstboot-1.8.0-1.git.3.006a990.el6.x86_64
subscription-manager-gui-1.8.0-1.git.3.006a990.el6.x86_64
subscription-manager-migration-data-1.12.2.6-1.git.0.171d4c3.el6.noarch


working fine resolving defect as verified
Comment 8 errata-xmlrpc 2013-02-21 03:56:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.