Bug 856605 - mingw-virt-viewer autoshares devices even when it should not based on the controller or USB filter settings
mingw-virt-viewer autoshares devices even when it should not based on the con...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-activex-win (Show other bugs)
3.1.0
Unspecified Windows
unspecified Severity high
: ---
: 3.2.0
Assigned To: Uri Lublin
Desktop QE
spice
: Reopened
: 870122 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 08:03 EDT by Milan Barta
Modified: 2016-02-10 15:21 EST (History)
20 users (show)

See Also:
Fixed In Version: spicex-win-3.2-1
Doc Type: Release Note
Doc Text:
Previously, when using the new Native USB Policy mode, connected USB devices were always shared regardless of whether the Enable USB Auto-Share option was selected. This issue has been resolved, and USB devices are correctly shared according to their setting in the Enable USB Auto-Share field.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:06:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Barta 2012-09-12 08:03:21 EDT
Description of problem:
Although option "Enable USB Auto-Share" in User Portal is unchecked when Native USB Policy is used, USB devices are still getting automatically connected to guest system by USBClerk (Windows client).
While the automatic USB device connection feature cannot be disabled yet, this option should be removed or at least disabled (greyed out).

Version-Release number of selected component (if applicable):
RHEVM 3.1.0-14.el6ev
usbclerk-win-0.1-7

Tested on: Windows 7 64-bit client

How reproducible:
Always

Steps to Reproduce:
1. Make sure that the VM's USB Policy is set to "Native"
2. Log into the UP and edit Console Options
3. Uncheck the "Enable USB Auto-Share" option and connect to the VM
4. Plug an USB device into the client machine while the RV window is in focus
  
Actual results:
USB device gets automatically connected to the guest system
RHEVM User Portal lets you disable USB Auto-Share even though it has no effect.

Expected results:
USB device is not automatically connected to the guest system
The "Enable USB Auto-Share" option is disabled or removed from the UP

Additional info:
Comment 3 David Jaša 2012-10-30 11:35:57 EDT
*** Bug 870122 has been marked as a duplicate of this bug. ***
Comment 4 David Jaša 2012-10-30 11:46:47 EDT
This bug is actually in mingw-virt-viewer that it does auto-share devices even when it should not, because autoshare is set to false in controller or the device should be blocked by filter settings.
Comment 5 Marc-Andre Lureau 2012-10-30 14:40:45 EDT
un-assigning, I am not working on this bug atm, anyone feel free to give some help..
Comment 10 Marc-Andre Lureau 2013-02-14 14:32:21 EST
afaict, the fix is included in spicex-win-3.2-1
Comment 12 Bill Sanford 2013-04-26 13:32:57 EDT
This is verified in RHEV-M 3.2 (sf14) with 0.5.3-23 virt-viewer.
Comment 13 errata-xmlrpc 2013-06-10 16:06:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0921.html

Note You need to log in before you can comment on or make changes to this bug.